Bug 226669 - Merge Review: zip
Summary: Merge Review: zip
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 21:37 UTC by Nobody's working on this, feel free to take it
Modified: 2009-12-10 15:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-10 15:20:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ruben: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 21:37:01 UTC
Fedora Merge Review: zip

http://cvs.fedora.redhat.com/viewcvs/devel/zip/
Initial Owner: varekova@redhat.com

Comment 1 Ruben Kerkhof 2007-02-04 11:38:07 UTC
Review for release 1.2.2:
* RPM name is OK
* Source zip231.tar.gz is the same as upstream
* Source zcrypt29.tar.gz is the same as upstream
* Builds fine in mock
* File list looks OK

Needs work:
* BuildRoot should be %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  (wiki: PackagingGuidelines#BuildRoot)
* Encoding should be UTF-8
* Missing SMP flags. If it doesn't build with it, please add a comment
  (wiki: PackagingGuidelines#parallelmake)
* Spec file: some paths are not replaced with RPM macros
  (wiki: QAChecklist item 7)

Minor:
* The latest version is 2.32

Notes:
* Please use {?dist} in the Release tag. See http://fedoraproject.org/wiki/DistTag for more info


Rpmlint is not silent:

Source RPM:
W: zip summary-ended-with-dot A file compression and packaging utility compatible with PKZIP.
E: zip tag-not-utf8 %changelog
W: zip invalid-license distributable
E: zip non-utf8-spec-file zip.spec
W: zip mixed-use-of-spaces-and-tabs (spaces: line 51, tab: line 47)

rpmlint of zip:
W: zip summary-ended-with-dot A file compression and packaging utility compatible with PKZIP.
E: zip tag-not-utf8 %changelog
W: zip invalid-license distributable


Comment 2 Ivana Varekova 2007-02-06 14:24:42 UTC
I have not updated to 2.32 - but everything else should be fixed in  zip-2.31-2.fc7.


Comment 3 Ruben Kerkhof 2007-02-06 21:04:30 UTC
Hi Ivana,

One last thing, please preserve timestamps when installing files (install -p or cp -p)

Comment 4 Ivana Varekova 2007-02-07 09:03:24 UTC
Fixed in zip-2.31-3.fc7

Comment 5 Ruben Kerkhof 2007-02-07 21:00:12 UTC
I don't think the file BUGS is very relevant and MANUAL is a duplicate of the manpage your already 
installing.

Please consider removing those.

I don't see any further blockers, so this package is approved.

Comment 6 Patrice Dumas 2007-02-16 20:31:12 UTC
Some suggestions:

* The crypt29 source seems to be unavailable. I have found:
  ftp://ftp.uu.net/pub/archiving/zip/src/zcrypt29.zip

* rename exec-shield.patch zip-exec-shield.patch

* add README.CR to %doc

* replace %defattr(-,root,root) with %defattr(-,root,root,-)

Comment 7 Marcin Garski 2007-04-05 11:44:39 UTC
* What's the reasons not updating to 2.32?

* I'm not sure but probably zcrypt29.zip can br droped.

As it states in crypt.c (from 2.31 and 2.32):

  The main encryption/decryption source code for Info-Zip software was
  originally written in Europe.  To the best of our knowledge, it can
  be freely distributed in both source and object forms from any country,
  including the USA under License Exception TSU of the U.S. Export
  Administration Regulations (section 740.13(e)) of 6 June 2002.

  Prior to January 2000, re-export from the US was a violation of US law.

Enc/dec in 2.3{2,1} are newer then in zrypt29.zip

* Drop BUGS, as in 2.32 we can read:
"This file is likely out of date
17 May 2006"

Comment 8 Patrice Dumas 2008-02-05 16:55:15 UTC
The bug should certainly be assigned to Ruben.

But the comments should also be addressed, in my opinion
the package is not really ready for inclusion without those
comments addressed.

Comment 9 Karel Klíč 2009-12-03 07:29:57 UTC
All comments are probably addressed now:

- zip is updated to 3.0 in rawhide
- zcrypt29.zip has been dropped
- exec-shield.patch has been renamed


Note You need to log in before you can comment on or make changes to this bug.