Bug 226719 - After beryl update, it now displays white screen!
After beryl update, it now displays white screen!
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: beryl-core (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
: Reopened
: 226798 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-01 02:09 EST by Jack Deslippe
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 14:44:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Deslippe 2007-02-01 02:09:55 EST
Description of problem:
After yum updating to the new beryl yesterday, it now shows the splash screen
when I load beryl, and then goes to a white screen!  I am using nvidia driver
and 64 bit fedora.  It seems quite a few people are having this problem.  See
the fedoraforum.org thread at
http://forums.fedoraforum.org/showthread.php?p=735634#post735634

Version-Release number of selected component (if applicable):
1.99.2-2

How reproducible:
yum update beryl from earlier version restart beryl.  I have tried deleting the
.beryl and .beryl-managerrc directory, but it did not fix problem.  

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Splash screen shows then goest to solid white screen.

Expected results:
the usually awesome berylness.

Additional info:
Comment 1 Jarod Wilson 2007-02-01 12:59:29 EST
*** Bug 226798 has been marked as a duplicate of this bug. ***
Comment 2 Jochen Schmitt 2007-02-01 15:54:01 EST
I use a nvidia graphic adapber too. After I have manualy upgrade the graphic
driver from 1.0-9742 (livna) to 1.0-9746 the reported problem doesn't occured
anymore on my computer. 
Comment 3 Jarod Wilson 2007-02-01 17:06:58 EST
Supposedly, this has been fixed upstream. I'm not seeing the issue here, so I
can't verify, nor do I have the time or desire to peck through changelogs to
find the specific fix, so unless someone else wants to do so, the fix probably
won't show up until there are new bery tarballs on releases.beryl-project.org... :\
Comment 4 Dawid Zamirski 2007-02-02 17:06:55 EST
Beryl 0.20 RC1 has just been released, hopefully we'll see it in extras soon :)
Comment 5 Joachim Kunze 2007-02-04 05:21:57 EST
I've encountered the same issues and I've installed the svn version of beryl as
suggested at http://forums.fedoraforum.org/showthread.php?p=735634#post735634 

This has resolved my issues with the white screen so it seems to be fixed upstream

Comment 6 Jarod Wilson 2007-02-04 13:03:10 EST
Humorous that someone in that forum is questioning a beryl "beta" being packaged... Technically, there 
hasn't been anything *but* a beta (or less) packaged so far, and 0.2.0 is slated to be the first "stable" 
release. I'm still quite dubious that a "stable" beryl release is possible... :)

I'll try to work on 0.1.9999.1 (aka 0.20 rc1, love the numbering scheme) tomorrow.
Comment 7 Jarod Wilson 2007-02-05 12:17:59 EST
0.1.9999.1 bits are almost done making their way through the build system
Comment 8 Joachim Kunze 2007-02-05 12:51:47 EST
Thanks a lot Jarod - well if just packaging a new snapshop is the solution -
easy ...
As I don't know what's the difference between these packages I don't know what's
the reason for the issue, but it actually works ;)

Thanks for packaging a new "official" version.

Cheers,

Jo
Comment 9 Jochen Schmitt 2007-02-05 13:18:13 EST
Yes, perhaps that is a mesa problem, which I don't understand. I was iritated,
becouse my system show a different behavour after I have installed the nvidia
driver von www.nvidia.com instead of the livna rpms.

Comment 10 Dawid Zamirski 2007-02-06 17:52:39 EST
I have just yum updated beryl to this new version and I'm still getting the
white screen. I'm using nvidia drivers from livna.

[maners@athlon64 ~]$ rpm -qa | grep beryl
beryl-plugins-0.1.9999.1-1.fc6
beryl-settings-simple-0.1.9999.1-2.fc6
beryl-manager-0.1.9999.1-1.fc6
beryl-gnome-0.1.9999.1-2.fc6
beryl-0.1.9999.1-2.fc6
beryl-core-0.1.9999.1-2.fc6
beryl-settings-0.1.9999.1-2.fc6
beryl-kde-0.1.9999.1-2.fc6

[maners@athlon64 ~]$ rpm -qa | grep nvidia
xorg-x11-drv-nvidia-1.0.9746-7.lvn6
xorg-x11-drv-nvidia-libs-32bit-1.0.9746-7.lvn6
kmod-nvidia-xen-1.0.9746-1.2.6.19_1.2895.fc6
kmod-nvidia-1.0.9746-1.2.6.19_1.2895.fc6

[maners@athlon64 ~]$ rpm -qa | grep mesa
mesa-libGL-6.5.1-9.fc6
mesa-libGLU-6.5.1-9.fc6
mesa-libGL-devel-6.5.1-9.fc6
mesa-libGLU-devel-6.5.1-9.fc6
mesa-libGLU-6.5.1-9.fc6
Comment 11 Dawid Zamirski 2007-02-06 18:03:29 EST
Update after starting beryl with --use-copy it works ok but I get low performance:
http://forum.beryl-project.org/viewtopic.php?f=36&t=2077

Compiz is working fine.
Comment 12 Jack Deslippe 2007-02-07 02:27:16 EST
the 0.1.9999 files do not fix the problem for me either.  I still have the same
white screen issue.  
Comment 13 Jarod Wilson 2007-02-07 11:17:58 EST
Argh. I've got a box I can reproduce this on now. Can work around it by hitting
up the beryl-manager menu -> advanced beryl options -> rendering path and
selecting copy instead of automatic. Not sure if the auto-detection broke or if
texture-from-pixmap support broke though... I'll poke around upstream a little.
Comment 14 Jarod Wilson 2007-02-07 14:44:37 EST
The beryl folks insist this is nVidia's problem.

http://bugs.beryl-project.org/ticket/848
http://bugs.beryl-project.org/ticket/875

So for now, use copy (or an XGL X server) w/the nvidia driver, I guess...
Re-closing CANTFIX, since the only place I can reproduce it is on a box using
the proprietary nvidia driver and upstream beryl says the bug isn't theirs... :\
Comment 15 Jarod Wilson 2007-02-23 10:04:07 EST
Okay, not nVidia's problem, its a build issue. See ticket bug 229778. This'll be
fixed in the next build.
Comment 16 Joachim Kunze 2007-03-22 02:51:21 EDT
Resolved for me with the newest beryl-0.2.0-1

Thanks,

Jo

Note You need to log in before you can comment on or make changes to this bug.