Bug 226814 - anaconda "loader" issue when using pxe kickstart w/ dhcp
anaconda "loader" issue when using pxe kickstart w/ dhcp
Status: CLOSED DUPLICATE of bug 189795
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-01 13:41 EST by Jack
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 11:25:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jack 2007-02-01 13:41:06 EST
Description of problem:
I know another kickstart/dhcp bug exists but I'm not sure if this is the same 
issue (since they seem to have working work arounds).  When attempting to 
install the OS via pxe boot, the loader reads the kickstart file but continues 
to ask for the network configuration after attempting to get dhcp 
information.  This occurs whether setting --bootproto to dhcp OR static 
(should I assume static options don't work when using pxe?).  I tried a 
variety of kernel arguments including; setting the linksleep to 30, 50, 80... 
etc, setting the nicdelay= option to multiple times, and using the 
eth0_ethtool="speed=100 autoneg=off duplex=full delay_link=1" option.  I've 
tried this with RHEL4U1-4 using x86_64 and intel architectures on multiple 
switches with no success.  I really can't believe this is still an issue given 
the current trend toward large HPC clusters and since Redhat also prides 
itself on simplicity to install.  Please advise me on any other options, keep 
in mind I will not have the ability to change switch settings.


Version-Release number of selected component (if applicable):
RHEL4 (UPDATE 1 through 4)

How reproducible:
Every time

Steps to Reproduce:
1. Create a dhcpd server with bootp and configure to install with kickstart 
(nsf or http).  I can only use Cisco switches - with default configurations - 
in this environment.
2. Boot the client machine w/ pxe, it recognizes dhcp and begins the install.  
A window shows the client is re-getting dhcp info.  Then the manual network 
card input menu appears (suggesting dhcp failed).
  
Actual results:
An input menu appears, dhcp fails.

Expected results:
No input menus - an entirely automated install process.

Additional info:
Comment 1 David Cantrell 2007-07-24 11:25:39 EDT

*** This bug has been marked as a duplicate of 189795 ***

Note You need to log in before you can comment on or make changes to this bug.