Bug 226825 - Xorg-1.1.1-47.5.fc6 (AMD64) segfaulted on Intel 945G
Summary: Xorg-1.1.1-47.5.fc6 (AMD64) segfaulted on Intel 945G
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-01 19:28 UTC by Ashish Shukla
Modified: 2018-04-11 15:20 UTC (History)
2 users (show)

Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 10:00:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (61.92 KB, text/plain)
2007-02-01 19:28 UTC, Ashish Shukla
no flags Details
Xorg configuration file (1.02 KB, text/plain)
2007-02-07 06:43 UTC, Ashish Shukla
no flags Details
Xorg log file when Xorg ran without xorg.conf (66.23 KB, text/plain)
2007-02-07 07:01 UTC, Ashish Shukla
no flags Details

Description Ashish Shukla 2007-02-01 19:28:06 UTC
Description of problem:
When trying to start or quit from 'SuperTux', X server crashed unexpectedly.

Version-Release number of selected component (if applicable):
xorg-x11-drv-penmount-1.1.0-2.1
xorg-x11-drv-vga-4.1.0-2.1
xorg-x11-drv-s3virge-1.9.1-2.1
xorg-x11-server-utils-7.1-4.fc6
xorg-x11-xfs-1.0.2-3.1
xorg-x11-drv-vesa-1.2.1-4
xorg-x11-drv-spaceorb-1.1.0-1.1
xorg-x11-drv-mutouch-1.1.0-2
xorg-x11-drv-citron-2.2.0-1.1
xorg-x11-drv-tdfx-1.3.0-2.fc6
xorg-x11-drv-mga-1.4.5-2.fc6
xorg-x11-drv-ast-0.81.0-3
xorg-x11-drv-calcomp-1.1.0-1.1
xorg-x11-docs-1.2-4.fc6
xorg-x11-drv-trident-1.2.3-1.fc6
xorg-x11-server-Xorg-1.1.1-47.5.fc6
xorg-x11-drv-void-1.1.0-3.1
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2
xorg-x11-drv-via-0.2.1-7
xorg-x11-drv-jamstudio-1.1.0-1.1
xorg-x11-util-macros-1.0.2-4.fc6
xorg-x11-xinit-1.0.2-15.fc6
xorg-x11-xkb-utils-1.0.2-2.1
xorg-x11-fonts-base-7.1-2
xorg-x11-drv-dmc-1.1.0-2
xorg-x11-proto-devel-7.1-9.fc6
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2
xorg-x11-drv-microtouch-1.1.0-1.1
xorg-x11-drv-cirrus-1.1.0-2.fc6
xorg-x11-drv-joystick-1.1.0-1.1
xorg-x11-drv-hyperpen-1.1.0-2
xorg-x11-xtrans-devel-1.0.1-1.1.fc6
xorg-x11-xdm-1.0.5-5.fc6
xorg-x11-resutils-7.1-2.fc6
xorg-x11-utils-7.1-2.fc6
xorg-x11-fonts-truetype-7.1-2
xorg-x11-drv-sisusb-0.8.1-4.1
xorg-x11-drv-aiptek-1.0.1-2
xorg-x11-drv-magictouch-1.0.0.5-2.1
xorg-x11-drv-vmmouse-12.4.0-2.1
xorg-x11-drv-i810-1.6.5-10.fc6
xorg-x11-drv-s3-0.5.0-1.fc6
xorg-x11-filesystem-7.1-2.fc6
xorg-x11-drv-palmax-1.1.0-1.1
xorg-x11-apps-7.1-3.fc6
xorg-x11-fonts-75dpi-7.1-2
xorg-x11-drv-fpit-1.1.0-1.1
xorg-x11-drv-acecad-1.1.0-2.1
xorg-x11-drv-savage-2.1.1-5.fc6
xorg-x11-drv-vmware-10.13.0-2.1
xorg-x11-xauth-1.0.1-2.1
xorg-x11-font-utils-7.1-2
xorg-x11-fonts-misc-7.1-2
xorg-x11-drv-siliconmotion-1.4.1-2.1
xorg-x11-drv-summa-1.1.0-1.1
xorg-x11-drv-magellan-1.1.0-1.1
xorg-x11-drv-dummy-0.2.0-2.1
xorg-x11-drv-fbdev-0.3.0-2
xorg-x11-xtrans-devel-1.0.1-1.1.fc6
xorg-x11-drv-ati-6.6.3-1.fc6
xorg-x11-drv-evdev-1.1.2-2.1
xorg-x11-drv-ur98-1.1.0-1.1
xorg-x11-fonts-Type1-7.1-2
xorg-x11-drv-digitaledge-1.1.0-1.1
xorg-x11-twm-1.0.1-3.1
xorg-x11-fonts-100dpi-7.1-2
xorg-x11-drv-elographics-1.1.0-1.1
xorg-x11-drv-voodoo-1.1.0-3.1
xorg-x11-drv-mouse-1.2.1-1.fc6
xorg-x11-drv-keyboard-1.1.0-2.1
xorg-x11-drv-sis-0.9.1-7
xorg-x11-drivers-7.1-3
xorg-x11-drv-dynapro-1.1.0-2
xorg-x11-drv-nv-1.2.0-4.fc6
xorg-x11-drv-elo2300-1.1.0-1.1
supertux-0.1.3-5.fc6
mesa-libGL-6.5.1-9.fc6
SDL-1.2.10-8.fc6
SDL_image-1.2.5-4.fc6
SDL_mixer-1.2.7-2.fc6
glibc-2.5-10.fc6
libstdc++-4.1.1-51.fc6

How reproducible:
Start or exit from 'SuperTux'. Not always reproducible.

Steps to Reproduce:
  
Actual results:
X server segfaulted.

Expected results:
X server should not segfault.

Additional info:
Xorg.0.log attached.

Comment 1 Ashish Shukla 2007-02-01 19:28:07 UTC
Created attachment 147132 [details]
Xorg log

Comment 2 Matěj Cepl 2007-02-06 00:04:58 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) to the bug report
as individual uncompressed file attachment using the bugzilla file attachment
link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.



Comment 3 Ashish Shukla 2007-02-07 06:43:36 UTC
Created attachment 147538 [details]
Xorg configuration file

Comment 4 Ashish Shukla 2007-02-07 07:01:59 UTC
Created attachment 147540 [details]
Xorg log file when Xorg ran without xorg.conf

Comment 5 Ashish Shukla 2007-02-07 07:07:27 UTC
Comment on attachment 147540 [details]
Xorg log file when Xorg ran without xorg.conf

When I ran without Xorg.conf I get a display of visible resolution 800x600
(looks like 800x600), but is actually 1024x768 (xrandr), where rest of pixels
were out of screen, to see them I've to scroll. Anyways, SuperTux crashed here
too. :(

Comment 6 Matěj Cepl 2007-12-10 09:24:57 UTC
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]

Comment 7 Ashish Shukla 2007-12-11 06:40:09 UTC
I stopped using Fedora due to bug 374521 in Fedora 8. But as far as I 
remember, I didn't encountered this bug in Fedora 7.

Comment 8 Matěj Cepl 2007-12-11 10:00:58 UTC
a) I think (I am not kernel maintainer, so not sure about their bugs) that bug
398281, where your bug leads to, is now fixed. Can we get you back? :-)
b) thanks, closing this bug as fixed on F7.


Note You need to log in before you can comment on or make changes to this bug.