Bug 22688 - /usr/bin/host is not reading entire search path
/usr/bin/host is not reading entire search path
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Need Real Name
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-21 14:58 EST by reedte
Modified: 2007-04-18 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-21 15:52:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description reedte 2000-12-21 14:58:07 EST
I am having a problem with /usr/bin/host from the package
bind-utils-8.2.2_P7-0.6.2.  It does not appear to read any domain from the
search path in resolv.conf after the first one listed.
For example:

$ cat /etc/resolv.conf
search icq.com aol.com
nameserver 207.69.188.185
$ host www
www.icq.com has address 205.188.147.56
www.icq.com has address 205.188.147.53
www.icq.com has address 205.188.252.121
$ host lotus
$ host lotus
$

At this point I change my resolv.conf to the following
$ cat /etc/resolv.conf
search aol.com icq.com
nameserver 207.69.188.185
$ host lotus
lotus.aol.com has address 205.188.147.121

And since there is www.aol.com host www is not relevent.  The point I
wanted to make was that when aol.com came after icq.com, the host command
returned nothing.  When I move aol up to the first item, host returns the
correct answer.  I did some more testing on this with my local lan (due to
supervisor's concern, I could not publish those results) and they confirmed
this.  In trying to duplicate this on other distro's someone mentioned to
me that it might be host.conf.  I have researched host.conf and gone to 6.0
distrubution that was working correctly and my host.confs are indentical.

$ cat /etc/host.conf
order hosts,bind
multi on

I also checked the nsswitch.conf. 

$ cat /etc/nsswitch.conf|grep hosts
hosts:      files nisplus nis dns

And finally here is my hosts file:
$ cat /etc/hosts
127.0.0.1               localhost.localdomain localhost

Now if it makes any difference, nslookup does not appear to have this
problem.  

I have searched long and hard for any other reference to this problem and
can't find any thing anywhere.  Please forgive me if this is a known
problem and there is a simple answer our there, or if I am just plain
blind.  

Thanks!!
--Toby Reed
Comment 1 Bernhard Rosenkraenzer 2001-02-20 13:06:21 EST
Fixed in the current version

Note You need to log in before you can comment on or make changes to this bug.