Bug 2269545 - nouveau with gsp: since VRR landed, login screen (gdm) is not shown, black screen
Summary: nouveau with gsp: since VRR landed, login screen (gdm) is not shown, black sc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 40
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: GNOME SIG Unassigned
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F40FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2024-03-14 15:05 UTC by Lukas Ruzicka
Modified: 2024-03-20 19:56 UTC (History)
9 users (show)

Fixed In Version: mutter-46.0-1.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-03-20 19:56:23 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME mutter issues 3337 0 None opened nouveau with gsp: since VRR landed, login screen (gdm) is not shown, black screen 2024-03-14 15:07:41 UTC
GNOME Gitlab GNOME mutter merge_requests 3646 0 None merged backends/native: Track CRTC support for signaling VRR 2024-03-18 16:22:23 UTC

Description Lukas Ruzicka 2024-03-14 15:05:47 UTC
This is for tracking purposes of the blocker review process. 
See the upstream bug report for details: https://gitlab.gnome.org/GNOME/mutter/-/issues/3337

Reproducible: Always

Comment 1 Fedora Blocker Bugs Application 2024-03-14 15:26:41 UTC
Proposed as a Blocker for 40-final by Fedora user lruzicka using the blocker tracking app because:

 I am proposing this as a blocker for Fedora final, because it violates the following boot criterion, see https://fedoraproject.org/wiki/Basic_Release_Criteria#Expected_installed_system_boot_behavior

There is a fix available for this which we have tested and is known to work:
https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3646

Comment 2 Fedora Update System 2024-03-18 16:23:35 UTC
FEDORA-2024-1ed0b13d87 (gnome-shell-46.0-1.fc40, gnome-shell-extensions-46.0-1.fc40, and 1 more) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-1ed0b13d87

Comment 3 Fedora Update System 2024-03-20 19:56:23 UTC
FEDORA-2024-1ed0b13d87 (gnome-shell-46.0-1.fc40, gnome-shell-extensions-46.0-1.fc40, and 1 more) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.