Bug 226970 - nspr-devel should require pkgconfig
nspr-devel should require pkgconfig
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nspr (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kai Engert (:kaie)
: EasyFix
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-02-02 07:04 EST by Matthias Saou
Modified: 2013-01-09 23:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-05 09:45:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2007-02-02 07:04:27 EST
While recompiling "js", I saw these errors :

/usr/bin/nspr-config: line 101: pkg-config: command not found
/usr/bin/nspr-config: line 101: pkg-config: command not found
/usr/bin/nspr-config: line 135: pkg-config: command not found
/usr/bin/nspr-config: line 141: pkg-config: command not found

For which the proper fix seems to be to add this to the nspr-devel sub-package:

Requires: pkgconfig
Comment 1 Matthias Saou 2007-02-05 09:03:58 EST
Adding as FC7Target. This should really be a trivial bug to fix, but needs fixing.
Also CC'ing Jesse since IIRC he had asked me to do so on "quickly fixable" bugs.
Comment 2 Kai Engert (:kaie) 2007-02-19 01:24:10 EST
Fix in my tree, will be shipped fc5/fc6/devel with upcoming new nspr package
release this week.
Comment 3 Kai Engert (:kaie) 2007-03-05 09:45:08 EST
fixed in fc5, fc6 and rawhide

Note You need to log in before you can comment on or make changes to this bug.