Bug 226988 - Install Fedora 7 Test 1 from DVD will not use free space on hard drive
Install Fedora 7 Test 1 from DVD will not use free space on hard drive
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Depends On:
  Show dependency treegraph
Reported: 2007-02-02 09:02 EST by Gerry Tool
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-02 12:21:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gerry Tool 2007-02-02 09:02:10 EST
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible: Always

Steps to Reproduce:
1. Download, check Sha1sum, Burn F7T1 desktop DVD, Check media - pass
2. Use Custom Partitioning, Try to add a new partition in free space
Actual results: Error message generated:
Could Not allocate requested partition.  Partitioning failed.  Could not
allocate partitions as primary partition. Not enough space left to create partiion.

Expected results: Create partition and format for installation.

Additional info: This is an AMD/Nvidia mainboard (Asus A8N-E) with one SATA
250GB drive, having 3 primary partitions, one extended partition containing 7
other logical partitions.  The new partition would be sda12.  There is 70GB free
space from which I requested a 10GB new partition.

I gave up and used one of the existing logical partitions (sda10) to install F7T1.
Comment 1 Chris Lumens 2007-03-02 10:46:07 EST
Could you please attach /tmp/anaconda.log from a failed installation to this bug
report?  We'd like to narrow down if this is an anaconda bug or a parted bug as
the error message you're seeing is sort of a catch-all.
Comment 2 Gerry Tool 2007-03-02 12:21:39 EST
I did a new install this morning, and of course everything worked, despite
having tried several times before I filed the bug.

However, I think I've figured out what happened.  A week or so ago, I decided to
try VMware and had to convert my winXP installation to a virtual copy.  I needed
disk space for this and using gparted discovered that the unallocated space was
not included in the extended partition (I have 3 other primary partitions.)  I
then increased the size of the extended partition to include all unallocated
space, and made a new logical partition with part of the space.

So, when I later installed Test 2 and this morning tried again with Test 1, the
free space was available to parted.

I will close this as NOTABUG.  The only improvement I could suggest is for
parted or anaconda to provide a different error message.  I see now that the
message "Could not allocate partitions as primary partition." was a hint, but
the following "Not enough space left to create partiion." left me confused.

Sorry for the false alarm and thanks for looking into it.

Note You need to log in before you can comment on or make changes to this bug.