Bug 2270128 - F40 live iso doesn't start at Basic Graphics Mode on BIOS
Summary: F40 live iso doesn't start at Basic Graphics Mode on BIOS
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 40
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: anaconda-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F40BetaFreezeException F40FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2024-03-18 14:25 UTC by Geraldo Simião
Modified: 2024-03-18 15:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-03-18 15:31:31 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
troubleshooting submenu (205.15 KB, image/jpeg)
2024-03-18 14:27 UTC, Geraldo Simião
no flags Details
what shows after choosing "boot second drive" (206.94 KB, image/jpeg)
2024-03-18 14:29 UTC, Geraldo Simião
no flags Details
it is basic graphics mode (42.67 KB, image/jpeg)
2024-03-18 15:13 UTC, Geraldo Simião
no flags Details

Description Geraldo Simião 2024-03-18 14:25:48 UTC
Just tested F40 Fedora-KDE-Live-x86_64-40_Beta-1.7.iso on a BIOs notebook and basic graphics mode doesn't start. If I try normal mode, with all drivers, it start normally and installs without errors.
F39 isos basic graphics mode start normally.

Reproducible: Always

Steps to Reproduce:
1.try to boot a new F40 beta 1.7 RC iso
2.go to Troubleshooting menu
3.choose boot first drive or boot second drive
Actual Results:  
choosing boot first drive it returns to the former menu
cooching boot second drive it shows only a black screen with GRUB and _ blinking. 

Expected Results:  
start a nomodeset live session

tested on this notebook:
Processors: 2 × Pentium® Dual-Core CPU T4500 @ 2.30GHz
Memory: 5.7 GiB of RAM
Graphics Processor: Mesa Mobile Intel® GM45 Express Chipset
Manufacturer: Hewlett-Packard
Product Name: HP G42 Notebook PC
sudo efibootmgr
EFI variables are not supported on this system.

Comment 1 Geraldo Simião 2024-03-18 14:27:57 UTC
Created attachment 2022340 [details]
troubleshooting submenu

Comment 2 Geraldo Simião 2024-03-18 14:29:08 UTC
Created attachment 2022341 [details]
what shows after choosing "boot second drive"

If I choose first drive it turns back to the former menu, if I choose second drive it show this output.

Comment 3 Fedora Blocker Bugs Application 2024-03-18 14:33:46 UTC
Proposed as a Blocker for 40-final by Fedora user geraldosimiao using the blocker tracking app because:

 As described on the criteria https://fedoraproject.org/wiki/Fedora_40_Final_Release_Criteria#basic-graphics-mode

Comment 4 Geraldo Simião 2024-03-18 14:48:57 UTC
Same problem with workstation image -> Fedora-Workstation-Live-x86_64-40_Beta-1.7.iso
On the same hardware

Comment 5 Kamil Páral 2024-03-18 14:54:04 UTC
> 3.choose boot first drive or boot second drive

You shouldn't boot from a hard drive. You should select "Start Fedora-KDE-Live 40_Beta in basic graphics mode", from the Troubleshooting menu. Do you not see it there?

Comment 6 Kamil Páral 2024-03-18 14:55:25 UTC
Actually, from comment 1, I see that the menu item *is* present, as the first one. Have you tried it?

Comment 7 Geraldo Simião 2024-03-18 15:10:33 UTC
(In reply to Kamil Páral from comment #6)
> Actually, from comment 1, I see that the menu item *is* present, as the
> first one. Have you tried it?

Yeah, I tried it, I choosed "Start Fedora-KDE-Live 40_Beta in basic graphics mode" and tried both options it shows to me.

I tried too with manualy adding "nomodeset" to the linux commandline and it doesn't boot

Comment 8 Geraldo Simião 2024-03-18 15:13:57 UTC
Created attachment 2022342 [details]
it is basic graphics mode

I tested both first and second drive, and both didn't boot.

Comment 9 Geraldo Simião 2024-03-18 15:14:29 UTC
I can do a screencast to show it

Comment 10 Adam Williamson 2024-03-18 15:20:58 UTC
Also proposing as a Beta FE.

Comment 11 Kamil Páral 2024-03-18 15:22:12 UTC
I tested both BIOS and UEFI with both KDE and Workstation (Beta 1.7), it works just fine on my B550 AM4 board.

Comment 12 Geraldo Simião 2024-03-18 15:31:31 UTC
Sorry folks, I redo the tests on both KDE and Worstation, as Kamil showed me and now basic graphics mode works fine. Was my fault chooseing wrong line att boot.


Note You need to log in before you can comment on or make changes to this bug.