Bug 22705 - helix-update won't work as normal user. Different behaviour than RH 6.2
helix-update won't work as normal user. Different behaviour than RH 6.2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: usermode (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-21 20:59 EST by Yusuf Goolamabbas
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-22 00:20:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace log of helix-update (94.26 KB, text/plain)
2000-12-21 21:00 EST, Yusuf Goolamabbas
no flags Details

  None (edit)
Description Yusuf Goolamabbas 2000-12-21 20:59:35 EST
Hi, I have installed RH 7.0 with all errata/updates and Helix Gnome 1.2
When I click on the helix-update icon or run helix-update from a shell as a
non-root user. I am prompted "You must be root to use Helix GNOME update"

This behaviour is different from that of RH 6.2

I have a strace log of helix-update also which I am going to try and send
to you. Can't figure out how to attach messages to bugzilla
Comment 1 Yusuf Goolamabbas 2000-12-21 21:00:41 EST
Created attachment 6657 [details]
strace log of helix-update
Comment 2 Bill Nottingham 2000-12-22 00:18:30 EST
1) An strace of any setuid program done as a normal user is not useful
   (setuid will not succeed in this case)
2) We don't provide helix-update; perhaps you should check with Helix Code?
Comment 3 Bill Nottingham 2000-12-22 00:20:03 EST
FWIW, it doesn't appear that whatever you're running is using usermode
at all, which would certainly explain the error.
Comment 4 Nalin Dahyabhai 2001-01-15 21:47:55 EST
The binary is not running with root privileges.  Since we don't ship the
package, we can't really fix it.

Note You need to log in before you can comment on or make changes to this bug.