Bug 22716 - RFE: Explicit 24/32 depth option, reverse order of multiple resolutions.
RFE: Explicit 24/32 depth option, reverse order of multiple resolutions.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-21 23:46 EST by Sam Varshavchik
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-21 23:47:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2000-12-21 23:46:59 EST
This laptop uses a Chips and Technologies F65550 (rev 198) VGA controller. 
The preferred video mode is 800x600x24.

Xconfigurator inserted "DefaultColorDepth 32" for this chip, limiting it to
a rather ugly 640x480 resolution.

I would like to revisit the issue of separately listing resolutions for
depth 24 and depth 32, in addition to 8bps and 16bps, instead of having
Xconfigurator keep track of which video cards use depth 24, and which video
cards use depth 32 for 24bps video mode.  This takes a whole bunch of
guesswork out of Xconfigurator.

Also, when multiple resolutions are selected for the same video mode, they
are written out into XF86Config with the lowest resolution listed first. 
This results in X starting in the lowest resolution mode.  It's probably
better to reverse the order of the resolutions, and have X start in the
highest resolution selected.

It might even be worthwhile to simplify this even further, and simply
generate all the possible resolutions, from highest to lowest.  Since X
automatically deletes resolutions it can't support for the video card, this
results in X being automatically configured for the highest possible
resolution available in the hardware.  Just have Xconfigurator prompt for
the video depth mode, and use that to initialize
defaultcolordepth/defaultdepth.
Comment 1 Preston Brown 2001-01-29 15:30:42 EST
resolutions have been reversed for the next release.  The other problem is much
harder to address without a major rewrite.

Note You need to log in before you can comment on or make changes to this bug.