Bug 2271837 - The KDE help center does not show the documentation for KDE applications.
Summary: The KDE help center does not show the documentation for KDE applications.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: khelpcenter
Version: 40
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F40FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2024-03-27 13:49 UTC by Lukas Ruzicka
Modified: 2024-04-13 03:41 UTC (History)
10 users (show)

Fixed In Version: khelpcenter-24.02.1-2.fc40 khelpcenter-24.02.1-3.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-04-13 03:41:22 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
wich link work and which don't (23.07 KB, image/jpeg)
2024-04-04 14:51 UTC, Geraldo Simião
no flags Details
This is how it behaves for me. (5.90 MB, video/mp4)
2024-04-11 15:14 UTC, Lukas Ruzicka
no flags Details
screenshot, link that works and link that doesn't work (175.60 KB, image/jpeg)
2024-04-11 15:34 UTC, Geraldo Simião
no flags Details


Links
System ID Private Priority Status Summary Last Updated
KDE GitLab system khelpcenter merge_requests 46 0 None opened Fix opening subpages of documentation 2024-04-06 17:16:30 UTC
KDE Software Compilation 484176 0 NOR UNCONFIRMED The KDE help center does not show the documentation for KDE applications. 2024-03-27 13:51:54 UTC

Description Lukas Ruzicka 2024-03-27 13:49:32 UTC
This is for tracking purposes, see https://bugs.kde.org/show_bug.cgi?id=484176 for the upstream report.

Reproducible: Always

Comment 1 Fedora Blocker Bugs Application 2024-03-27 13:54:42 UTC
Proposed as a Blocker for 40-final by Fedora user lruzicka using the blocker tracking app because:

 The Help Center application is helpless and thus violates the Defaul application criterion.

Comment 2 Neal Gompa 2024-04-01 05:45:44 UTC
Does it reproduce with the Plasma 6.0.3 / Gear 24.02.1 update? https://bodhi.fedoraproject.org/updates/FEDORA-2024-abe8896868

Comment 3 Geraldo Simião 2024-04-01 14:20:55 UTC
Tested with khelpcenter-24.02.1-1.fc40.x86_64, bug still present.

Comment 4 Geraldo Simião 2024-04-01 14:31:19 UTC
I updated the upstream report with my findings.

Comment 5 Neil Hanlon 2024-04-01 16:26:16 UTC
Discussed at the 2024-04-01 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/

This was accepted as a Release Blocker as a violation of Final criterion:

"For all release-blocking desktop / arch combinations, the following applications must start successfully and withstand a basic functionality test: ... help viewer"

Comment 7 Geraldo Simião 2024-04-04 14:51:26 UTC
Created attachment 2025229 [details]
wich link work and which don't

If I do a search on help center, for the same kcalc I found this results. Clicking on the same chapter link it give me the correct doc.Note that the working link is different from the buggy one.

Comment 8 Neal Gompa 2024-04-06 17:16:31 UTC
Nicolas Fella has made a fix for this upstream: https://invent.kde.org/system/khelpcenter/-/merge_requests/46

Comment 9 Fedora Update System 2024-04-06 19:03:15 UTC
FEDORA-2024-12745d4cb3 (khelpcenter-24.02.1-2.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-12745d4cb3

Comment 10 Fedora Update System 2024-04-07 02:12:21 UTC
FEDORA-2024-12745d4cb3 has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-12745d4cb3`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-12745d4cb3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2024-04-08 00:12:41 UTC
FEDORA-2024-12745d4cb3 (khelpcenter-24.02.1-2.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Nicolas Fella 2024-04-08 20:37:15 UTC
https://invent.kde.org/system/khelpcenter/-/merge_requests/48 has a better fix, please use that

Comment 13 Lukas Ruzicka 2024-04-11 13:18:14 UTC
I am not sure whether Comment 12 has been backported to Fedora, but I am still seeing the same behaviour on Fedora RC 1.13. I am reopening the bug. We will try to build the above fix from Nicolas and come back with more info.

Comment 14 Adam Williamson 2024-04-11 14:56:06 UTC
Three reporters in https://bodhi.fedoraproject.org/updates/FEDORA-2024-12745d4cb3 said the update worked to fix this bug...can you say exactly what your reproduction procedure is, Lukas, and some more people can try and see if they also hit this?

Comment 15 Adam Williamson 2024-04-11 15:02:10 UTC
ah, hmm, seems like https://invent.kde.org/system/khelpcenter/-/merge_requests/46#note_915071 and https://invent.kde.org/system/khelpcenter/-/merge_requests/46#note_915062 explain what the initial fix (which is what we currently have) broke. :/

Comment 16 Geraldo Simião 2024-04-11 15:03:58 UTC
I just tested here Fedora-KDE-Live-x86_64-40-1.13.iso and khelpcenter is doing fine, can't reproduce this bug anymore.

Comment 17 Adam Williamson 2024-04-11 15:08:32 UTC
Can you try the things mentioned in the upstream comments? Links that have anchors, and links within the help for a given app?

Comment 18 Lukas Ruzicka 2024-04-11 15:10:54 UTC
(In reply to Adam Williamson from comment #14)
> Three reporters in
> https://bodhi.fedoraproject.org/updates/FEDORA-2024-12745d4cb3 said the
> update worked to fix this bug...can you say exactly what your reproduction
> procedure is, Lukas, and some more people can try and see if they also hit
> this?

Sure. When I open the Help Centre, the Help documentation opens fine. As far as I click into the left bar, the expected documents are seen in the right part of the application. So far, so good. However, when I start clicking on the subtopic in the right part of the application, many times I get "documentation not found." I will try to record a screencast.

Comment 19 Lukas Ruzicka 2024-04-11 15:14:58 UTC
Created attachment 2026365 [details]
This is how it behaves for me.

Comment 20 Geraldo Simião 2024-04-11 15:23:30 UTC
ok, I navigate a little further now, trying to enter all links and chapters in different ways...
now one of them returned the error message, so, not so perfectly working for me too.
Tried six different pages, one returned the error.

Here a screencast: https://geraldosimiao.fedorapeople.org/Screencasts/new-test-helpcenter-2024-04-11_12-16-56.mp4

Comment 21 Geraldo Simião 2024-04-11 15:34:18 UTC
Created attachment 2026369 [details]
screenshot, link that works and link that doesn't work

here is an example from akregator at helpcenter. One of the link return doc not found, all the others are ok.

Comment 22 Geraldo Simião 2024-04-11 15:36:01 UTC
(In reply to Adam Williamson from comment #17)
> Can you try the things mentioned in the upstream comments? Links that have
> anchors, and links within the help for a given app?

yup, especialy the "links within the help" are problematic now in the version khelpcenter-24.02.1-2

Comment 23 Fedora Update System 2024-04-11 20:05:13 UTC
FEDORA-2024-f2d3a65ad5 (khelpcenter-24.02.1-3.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-f2d3a65ad5

Comment 24 Fedora Update System 2024-04-12 02:05:41 UTC
FEDORA-2024-f2d3a65ad5 has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-f2d3a65ad5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-f2d3a65ad5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 25 Fedora Update System 2024-04-13 03:41:22 UTC
FEDORA-2024-f2d3a65ad5 (khelpcenter-24.02.1-3.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.