Bug 22720 - Cannot compile pnm utilities; pbmplus.h includes nonexistent shhopt.h
Summary: Cannot compile pnm utilities; pbmplus.h includes nonexistent shhopt.h
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netpbm   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Wil Harris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-22 07:23 UTC by jbednar
Modified: 2015-03-05 01:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-22 07:23:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jbednar 2000-12-22 07:23:46 UTC
At least with my RedHat 7.0 system, it appears impossible to compile a
program using the netpbm-devel headers.  Those headers usually include
pbmplus.h, which in turn includes <shhopt.h>, which doesn't appear to
exist.  (It may be in the default distribution, and not on my system due to
some package I did not install, but if so then there is a missing
dependency for netpbm-devel.)  The only version of a shhopt.h that I could
find was in util-linux-2.10m-12.src.rpm, and although that appears related
to the desired file it does not contain everything pbmplus.h is looking
for. 

So, how did you compile the pnm utilities?  How should a user compile his
own? Where is shhopt.h?

Thanks.

Example:
> cat bug21.c
#include <pbmplus.h>
> gcc -c bug21.c
In file included from bug21.c:1:
/usr/include/pbmplus.h:305: shhopt.h: No such file or directory
> locate shhopt.h
> rpm -qf /usr/include/pbmplus.h
netpbm-devel-9.5-5

Comment 1 Phil Knirsch 2000-12-22 09:37:32 UTC
Works in the current release. /usr/include/netpbm.h does now

#include <pbmshhopt.h>

in line 323, which is also part of netpbm-devel.


Comment 2 jbednar 2000-12-22 19:42:14 UTC
I'm assuming by "current release" you are referring to the rawhide distribution,
so I downloaded netpbm-*9.8-2.i386.rpm, and indeed that version does fix the
problem. However, shouldn't this be an erratum on the updates page for RH7.0? 
It effectively prevents the use of netpbm-devel altogether, and users won't know
that they need to get the RPMs from rawhide instead...

Thanks,

Jim


Note You need to log in before you can comment on or make changes to this bug.