Bug 227203 - idr_remove called for id=0 which is not allocated.
Summary: idr_remove called for id=0 which is not allocated.
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Aristeu Rozanski
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-03 14:29 UTC by Bernd Bartmann
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 15:05:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of dmesg (23.96 KB, text/plain)
2007-02-03 14:29 UTC, Bernd Bartmann
no flags Details
Yet another dmesg output this time from an FC7T1 system x86_64 (26.98 KB, text/plain)
2007-02-03 21:02 UTC, Bernd Bartmann
no flags Details
testcase (4.78 KB, text/x-csrc)
2007-03-10 14:26 UTC, Aristeu Rozanski
no flags Details

Description Bernd Bartmann 2007-02-03 14:29:15 UTC
Description of problem:
During boot-up of kernel-2.6.19-1.2895 on a P4 with HT I get a call trace.
Please have a look at the attached output of dmesg.


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.2895

How reproducible:


Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Bernd Bartmann 2007-02-03 14:29:16 UTC
Created attachment 147273 [details]
output of dmesg

Comment 2 Bernd Bartmann 2007-02-03 21:02:54 UTC
Created attachment 147282 [details]
Yet another dmesg output this time from an FC7T1 system x86_64

Attached another dmesg output, this time from an FC7T1 x86_64 system (DELL
Latitude D620 laptop).

BTW: There is no product / version for FC7T1 in Bugzilla yet.

Comment 3 Aristeu Rozanski 2007-03-09 20:36:50 UTC
Can you test the kernel on http://people.redhat.com/arozansk/ptytest/fc6/ and tell
me if you can reproduce the problem?
Thanks,


Comment 4 Bernd Bartmann 2007-03-10 11:11:06 UTC
Just installed the i686 ptytest kernel on the FC6 PIV HT system. I couldn't see
the error message so far. Is there any way to trigger the error?

Comment 5 Aristeu Rozanski 2007-03-10 14:26:27 UTC
Created attachment 149770 [details]
testcase

This testcase (compile with gcc -lpthread -o pty_testcase pty_testcase.c)
triggers
the error much more easily on some machines. You may test this testcase with
your
unpatched kernel to check if it triggers then boot on the patched kernel to
verify.

Beware: this message you're hitting may cause another bigger bug that makes
impossible to allocate more ptys, thus you won't be able to open other openssh
sessions, so it's recommended it's tested in a local machine.

Comment 6 Bernd Bartmann 2007-03-10 19:36:49 UTC
Ok, tested pty_testcase on 2.6.19-1.2911.6.5.fc6 (latest FC6 kernel update). On
this kernel the bug is 100% reproducible and fills /var/log/messages with call
traces.

I can't reproduce the problem on the test kernel 2.6.20-1.2922.fc6.ptytest.
ptytest keeps running with no output at all and nothing is logged to
/var/log/messages.



Comment 7 Aristeu Rozanski 2007-03-12 15:05:48 UTC
I just checked and the fix were included on the latest FC-6 CVS kernel, so it'll
be available on the next update. If it's still reproducible on kernel versions
newer than 2.6.20-1.2925, please reopen this ticket.
Thanks



Note You need to log in before you can comment on or make changes to this bug.