Bug 22721 - PHP Binary does not work under Apache
Summary: PHP Binary does not work under Apache
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Need Real Name
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-22 07:29 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-22 07:29:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-12-22 07:29:11 UTC
I have been unable to get the PHP binary to work as a CGI under apache. 
Running the script on the command-line works just fine and seems to output
all the correct information, however when the script is accessed under
apache, a 500 error is returned, and the logfiles show "Premature end of
script headers."  mod_php, however, works just fine.

Comment 1 Nalin Dahyabhai 2001-01-16 02:45:59 UTC
To use the PHP binary, you need to add this to your httpd.conf file:
	Action php-handler /cgi-bin/php
	AddHandler php-handler .php4 .php3 .phtml .php
...and copy the php binary from /usr/bin to /var/www/cgi-bin (where we don't put
it by default because it might cause problems on "Everything" installs).



Note You need to log in before you can comment on or make changes to this bug.