Bug 227238 - "Filter" feature should be "Search", and support synonyms
Summary: "Filter" feature should be "Search", and support synonyms
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-03 21:40 UTC by Dave Malcolm
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-15 16:11:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Malcolm 2007-02-03 21:40:27 UTC
Description of problem:
Launch control-center, click on Filter and start typing "compiz"
At "com" and beyond: get "No matches found" etc

Looks like it's only searching the explicit text for the items.  It should
search inside various synonyms etc, so e.g. "compiz" should match "Desktop Effects".

Similarly:
- "wallpaper" matches nothing; it ought to match "Desktop Background"
- "accessibility" only matches "Keyboard accessibility"; it ought to also match
Assistive Technology
- "a11y" matches nothing; should match the ones above
- "software" matches nothing: should match a launcher for "Add/Remove Software"
- "browser" matches nothing: should match "Preferred Applications"
- "terminal" matches nothing: should match "Preferred Applications"
- "mail" matches nothing: should match "Preferred Applications"
etc 

Should also be "Search" not "Filter"

Version-Release number of selected component (if applicable):
control-center-2.17.90-3.fc7

Comment 1 Dave Malcolm 2007-02-03 21:43:15 UTC
"disk" matches nothing; should match "Removable Drives"

Comment 2 Bastien Nocera 2007-02-15 16:11:35 UTC
Already reported at:
http://bugzilla.gnome.org/show_bug.cgi?id=399754

As this interface is now disabled by default, I'll close this bug and push your
comments upstream where they'll have more impact.


Note You need to log in before you can comment on or make changes to this bug.