Bug 22727 - Internal compiler error in pop_binding
Summary: Internal compiler error in pop_binding
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-22 10:37 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-29 06:51:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.ii file for the bug (386.06 KB, text/plain)
2000-12-29 06:46 UTC, Need Real Name
no flags Details

Description Need Real Name 2000-12-22 10:37:17 UTC
Compiling on an Intel Pentium (no bloody II, III, or IV) mysql-3.23.29a-
gamma, received following error message:

nclude                  -I./../regex                    -I. -I../include -
I.. -I
.    -O3 -DDBUG_OFF   -fno-implicit-templates -c field_conv.cc
In file included from item.h:344,
                 from mysql_priv.h:218,
                 from field_conv.cc:25:
item_func.h:252: Internal compiler error in pop_binding, at
../gcc/cp/decl.c:1206
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [field_conv.o] Error 1
make[3]: Leaving directory `/home/elendur/.websvr/mysql-3.23.29a-gamma/sql'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/elendur/.websvr/mysql-3.23.29a-gamma/sql'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/elendur/.websvr/mysql-3.23.29a-gamma'
make: *** [all-recursive-am] Error 2

Comment 1 Jakub Jelinek 2000-12-22 10:42:31 UTC
Do you have the errata gcc-c++ installed (2.96-69)?
If no, please install it, if yes, then please rerun the g++ command
with -save-temps -v options and attach here the generated .ii file together
with all the options passed to g++.

Comment 2 Need Real Name 2000-12-23 15:30:10 UTC
Yes 2.96-69 is installed.  I'm not quite sure what to enter where to do the second part however.

Comment 3 Jakub Jelinek 2000-12-27 11:13:13 UTC
Cut'n'paste the g++ command to build field_conv.cc onto the command line
(you pasted above only a part of it, so it should include at least
g++ -I./../regex -I. -I../include -I.. -I. -O3 -DDBUG_OFF -fno-implicit-templates -c field_conv.cc
but probably some other options as well and add -save-temps -v to that command
line as well.
g++ will generate field_cc.ii file in the current directory, that's what I'm
interested in in addition to the exact command line you typed.

Comment 4 Need Real Name 2000-12-29 06:46:50 UTC
Created attachment 6785 [details]
.ii file for the bug

Comment 5 Need Real Name 2000-12-29 06:51:46 UTC
After attempting to reproduce the bug, I found that it didn't happen on the same file every time.  I modified the config files to pass those arguments to all c++ commands and I have attached the .ii file from the step the bug occurred on this time.
Immediately after the bug occurred the first time, I backed up gcc and made it a link to kgcc.  The program compiled fine.  Since then, I have restored the gcc backup and attempted to make several times, always encountering an internal error, but never on the same file.  Always a .cc file in the sql directory, it has twice said internal error in pop_binding and twice said internal error: segmentation fault.

Comment 6 Jakub Jelinek 2001-01-04 15:20:32 UTC
Cannot reproduce this (have tried to build several times your .ii file without
a single problem with various options and rebuilt mysql-3.23.29a-gamma
without a problem either). I suspect bad memory chips or something like that.


Note You need to log in before you can comment on or make changes to this bug.