Bug 22728 - End key doesn't work with -nw
Summary: End key doesn't work with -nw
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: emacs   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-22 11:16 UTC by Tim Waugh
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-22 11:16:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2000-12-22 11:16:23 UTC
With emacs-X11, Home and End work fine (beginning and end of buffer,
respectively).  But when I start 'emacs -nw' in a gnome-terminal (also
tried rxvt), the Home key works but the End key doesn't (just beeps).

In an xterm it's even worse because not even the Home key works.

(I think this problem is present in Guinness too.)

Comment 1 Trond Eivind Glomsrxd 2000-12-26 23:01:18 UTC
"home" and "end" aren't supported in many text terminals - to get it working, 
either find out which events the keys represent and bind them to your desired 
events or use the better way (ctrl-a, ctrl-e - works fine in bash and many 
other applications as well)


Note You need to log in before you can comment on or make changes to this bug.