Bug 227343 - FC7T1 : Error informing the kernel about modifications to partition
FC7T1 : Error informing the kernel about modifications to partition
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-02-05 09:50 EST by Thomas Canniot
Modified: 2007-12-28 15:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 14:46:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda dump (126.63 KB, text/plain)
2007-02-10 02:33 EST, Jason Farrell
no flags Details
anaconda.log (16.43 KB, text/plain)
2007-03-30 02:40 EDT, Thomas Canniot
no flags Details
lslRproc (169.25 KB, application/octet-stream)
2007-03-30 02:41 EDT, Thomas Canniot
no flags Details
anaconda.log (18.67 KB, text/plain)
2007-04-01 06:53 EDT, Jason Farrell
no flags Details
syslog (52.94 KB, text/plain)
2007-04-01 06:54 EDT, Jason Farrell
no flags Details
fdisk -l (3.98 KB, text/plain)
2007-04-01 06:54 EDT, Jason Farrell
no flags Details
parted sd{a..j} print (5.26 KB, text/plain)
2007-04-01 06:55 EDT, Jason Farrell
no flags Details
anaconda.log (new) (17.13 KB, application/octet-stream)
2007-04-02 08:28 EDT, Thomas Canniot
no flags Details
fdisk -l command print (968 bytes, text/plain)
2007-04-02 08:29 EDT, Thomas Canniot
no flags Details
lslRproc.txt (169.39 KB, text/plain)
2007-04-02 08:31 EDT, Thomas Canniot
no flags Details
parted-sda.txt (751 bytes, text/plain)
2007-04-02 08:31 EDT, Thomas Canniot
no flags Details
parted-sdb.txt (385 bytes, text/plain)
2007-04-02 08:32 EDT, Thomas Canniot
no flags Details

  None (edit)
Description Thomas Canniot 2007-02-05 09:50:13 EST
Description of problem:


Version-Release number of selected component (if applicable):
FC7T1 DVD Desktop set

How reproducible:
Always

Steps to Reproduce:
Here is my harddrive snapshot : 

[sda1 - NTFS][sda5 (sda6 - ext3)(sda7 - swap)(sda8 - ext3)(sda9 - ext3)]

I tried to install FC7 with DVD Desktop spin. I chose a partition on my driver
that I deserve to testing (/dev/sda8). Anaconda accepts this partition but right
after I validate to launch the installation process, a error box appears instead
of the formating progress box. The error is the following : 
"Error informing the kernel about modifications to partition /dev/sda5 -
peripheral busy. This means Linux won't know about changes you made to /dev/sda5
until you reboot - so you shouldn't mount it or use it in any way before rebooting."
Then a bugbuddy window appears telling the above message comes from parted. Ths
windows also advises reporting a bug against anaconda.

Actual results:
No installation is possible.
Comment 1 Thomas Canniot 2007-02-05 09:55:24 EST
Oh, when I click on 'Debug' from bugbuddy, the tty whell points to
/usr/lib/anaconda/partedUtils.py(869)SavePartitions()

Hope this helps.
Comment 2 Jason Farrell 2007-02-10 02:33:41 EST
Created attachment 147830 [details]
anaconda dump
Comment 3 Jason Farrell 2007-02-10 02:34:26 EST
This is the same error that is preventing my F7T1 install, but in my case I'm
not even telling the installer to make ANY changes to the partition table, since
I'm simply installing into a pre-existing partition where FC6T3 used to live,
and re-using swap.
Comment 4 Jason Farrell 2007-02-10 02:52:38 EST
Also, it looks like it tried (and thankfully failed) to partition the WRONG
drive (sdi). I told to installer to leave all my other drives untouched, and to
install to sdj2 with swap on sdj5, but it's complaining about a drive that's off
by one less.

With the new libata, the installer listed my drives as:
sda: external sata drive on sata_sil - h/w raid1 with single ntfs part
sdb - sde: sata drives on sata_nv
sd? - my USB flash drive
sdi - my 120GB PATA drive (primary master. previously /dev/hda)
sdj - my 80GB PATA drive (secondary slave. /dev/hdd)

Maybe this has something to do with usb devices being sandwiched between the
scsi/sata drives and the old pata drives? (I'll attempt another install with all
my usb devices unplugged.)
Comment 5 Thomas Canniot 2007-02-21 16:41:07 EST
I tried with all the usb devices unplugged and had the same error.
Comment 6 Thomas Canniot 2007-03-10 03:30:13 EST
Do you need extras info to resolve this bug ? Will it be resolved before F7T3
release ? I really want to test Fedora 7 to report bug, but this one prevents me
from installing it.

Thanks.
Comment 7 David Cantrell 2007-03-12 11:09:03 EDT
I'm going to get parted-1.8.3 released and merged in.  We've got a lot of bug
fixes in that release and I'd prefer to get that in rawhide and then go from there.
Comment 8 David Cantrell 2007-03-21 10:59:45 EDT
I've released up through parted-1.8.6 and hopefully that will fix your issue. 
It will be present in F7T3.  Please test F7T3 when it's released and let me know
if the issue has been resolved.

Thanks.
Comment 9 Thomas Canniot 2007-03-29 14:10:17 EDT
It still doesn't work in FC7 Test 3.
Comment 10 David Cantrell 2007-03-29 14:16:32 EDT
Can you attach /tmp/anaconda.log to the bug report?
Comment 11 Jeremy Katz 2007-03-29 16:26:01 EDT
Also, 'ls -lR /proc' might be interesting to see if there's anything holding the
partition table open.
Comment 12 Thomas Canniot 2007-03-30 02:40:12 EDT
Created attachment 151258 [details]
anaconda.log
Comment 13 Thomas Canniot 2007-03-30 02:41:14 EDT
Created attachment 151259 [details]
lslRproc
Comment 14 David Cantrell 2007-03-30 09:53:35 EDT
Can you change over to a shell (Ctrl+Alt+F2) and run:

parted /dev/sda print > /tmp/parted-sda.txt
parted /dev/sdb print > /tmp/parted-sdb.txt

And for comparison:

fdisk -l > /tmp/fdisk.txt

Attach /tmp/parted-sda.txt, /tmp/parted-sdb.txt, and /tmp/fdisk.txt to this bug
report.

Thanks.
Comment 15 Jason Farrell 2007-04-01 06:51:50 EDT
I'm still affected by this bug in test3 on my hardware. I tell anaconda that I
ONLY want it to install to my pre-existing sdj2 partition which is on my spare
80GB secondary slave PATA drive, and to reuse swap (sdj5), and yet the "error
informing the kernel about modifications..." is for sdi5, which is my 120GB
primary master PATA drive (where my windows, extra swap, extra NTFS part, and
s/w raid partition lives).

I have no idea why it would be complaining about sdi5 (which happens to my extra
NTFS partition) since it's not supposed to be touching that drive anyway. off by
one bug?

Attachments to follow:
Comment 16 Jason Farrell 2007-04-01 06:53:36 EDT
Created attachment 151380 [details]
anaconda.log
Comment 17 Jason Farrell 2007-04-01 06:54:13 EDT
Created attachment 151381 [details]
syslog
Comment 18 Jason Farrell 2007-04-01 06:54:56 EDT
Created attachment 151382 [details]
fdisk -l
Comment 19 Jason Farrell 2007-04-01 06:55:22 EDT
Created attachment 151383 [details]
parted sd{a..j} print
Comment 20 David Cantrell 2007-04-01 11:28:22 EDT
(In reply to comment #15)
> I'm still affected by this bug in test3 on my hardware. I tell anaconda that I
> ONLY want it to install to my pre-existing sdj2 partition which is on my spare
> 80GB secondary slave PATA drive, and to reuse swap (sdj5), and yet the "error
> informing the kernel about modifications..." is for sdi5, which is my 120GB
> primary master PATA drive (where my windows, extra swap, extra NTFS part, and
> s/w raid partition lives).
> 
> I have no idea why it would be complaining about sdi5 (which happens to my extra
> NTFS partition) since it's not supposed to be touching that drive anyway. off by
> one bug?
> 
> Attachments to follow:

Where are you telling anaconda to write the boot loader?

The error messages from the partitioning interface are not always exactly
correct.  Based on the parted output, I see that two devices report no medium
found (sdg and sdh), which are before sdi.  Are these actual disks or some sort
of flash drive?
Comment 21 Jason Farrell 2007-04-01 18:19:01 EDT
(In reply to comment #20)
> Where are you telling anaconda to write the boot loader?

In this case I told the installer to SKIP installing grub at all (it wanted to
install to sdi's MBR by default, btw, even though sdi isn't my first bios boot
drive). Usually I'll install it to the ROOT partition for test releases, and to
my actual MBR (on sata raid1) for final releases.
 
> The error messages from the partitioning interface are not always exactly
> correct.  Based on the parted output, I see that two devices report no medium
> found (sdg and sdh), which are before sdi.  Are these actual disks or some sort
> of flash drive?

There are no other obvious storage devices connected. sdg and sdh are unknown to
me. I did have to manually select the PATA_AMD driver to begin the installation
from DVD, so maybe it's related?

Though grepping the syslog reveals them to be distinct:
<5>sd 9:0:0:0: Attached scsi removable disk sdf
<5>sd 8:0:0:0: Attached scsi removable disk sdg
<5>sd 8:0:0:1: Attached scsi removable disk sdh
<5>scsi 11:0:0:0: CD-ROM            _NEC     DVD_RW ND-3520A  1.04 PQ: 0 ANSI: 5
Comment 22 Thomas Canniot 2007-04-02 08:28:23 EDT
Created attachment 151417 [details]
anaconda.log (new)

I went farther and the og file displays errors this time
Comment 23 Thomas Canniot 2007-04-02 08:29:38 EDT
Created attachment 151418 [details]
fdisk -l command print
Comment 24 Thomas Canniot 2007-04-02 08:31:00 EDT
Created attachment 151419 [details]
lslRproc.txt

New file with the diplay of the bug on screen while excuting the command.
Comment 25 Thomas Canniot 2007-04-02 08:31:41 EDT
Created attachment 151420 [details]
parted-sda.txt
Comment 26 Thomas Canniot 2007-04-02 08:32:27 EDT
Created attachment 151421 [details]
parted-sdb.txt
Comment 27 cornel panceac 2007-04-10 02:43:18 EDT
the error is still here, on f7t3, here's my 'original' report from the test
mailing list :)

i've searched the list but i haven't found somebody else reporting this, so
here's the bug i've encountered while tryin' to install f7 t3.

the target:

one hard disk (pata) with several partitions, including one valid fc6 install
splitted on: /boot, /, /home and swap.
another partition is supposed to be the f7t3 /, and another is supposed to be
the f7t3 /home.

install starts just fine and after spending _a lot_ of time (amd barton 1833)
while solving dependecies, right before it was supposed to format partiions, it
prompts to ignore one error or exit. the error states that (anaconda?) "failed
to inform the kernel about changes to /dev/hda5 and (some garbage)" . whether
you choose to ignore the error or choos to exit, in both cases will exit.

worth mentioning that the partiion table was not suppose to be changed, and
/dev/hda5 is not supposed to be used during the install of f7t3, since is part
of hte existing fc6 install, and is not even mounted.

after reboot, the partiion table is still, there, no partition has been formatted.

the error shows up on both livecdinstall, or dvd install.

same dvd, used on another machine where all partitions become part of f7t3 (even
if one, /home, is not formatted), worked just fine.

unfortunately the machine where install failed, is offline so i report from
memory :)

Comment 28 Diego 2007-04-14 14:26:41 EDT
This bug is present since Fedora 4 and is present also in CentOS 5:
http://bugs.centos.org/view.php?id=1906
Comment 29 David Cantrell 2007-04-26 14:46:48 EDT
Well, I can't reproduce this problem using rawhide as of today.  I'm using the
same partition layout as indicated in the opening comment for this bug.
Comment 30 Diego 2007-12-28 15:33:37 EST
Little news from a subscriber of this bug.

NOTE: I have never changed my partion table during these tests.

While with Fedora 4 up to Fedora 7 after the message:
"Error: Error informing the kernel about modifications to partition /dev/hda5 --
Dispositivo o risorsa occupata. This means Linux won't know about any changes
you made to /dev/hda5 until you reboot -- so you shouldn't mount it or use it in
any way before rebooting."
another message appears:
"Exception Occurred: An unhandled exception has occurred. This is most likely a
bug. Please save a detailed copy of the detailed exception and file a bug report
against anaconda at http://bugzilla.redhat.com/"
and then the installation stops and the system restarts, with Fedora 8 (both
Live and Installer) the first message still appears but the second message
appears no more and the installation starts and completes correctly.

Note You need to log in before you can comment on or make changes to this bug.