Bug 227350 - X-term window size and position changing unexpectedly
Summary: X-term window size and position changing unexpectedly
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: clusterssh   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Duncan Ferguson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 15:52 UTC by Vlado Potisk
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 19:29:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vlado Potisk 2007-02-05 15:52:08 UTC
Description of problem:
There seems to be some undesirable interaction between clusterssh and KDE. After
switching desktops the position and sometimes also the size of the two X-term
windows change in some cases. That is really annoying, because it leads to
confusion which host is which.

Version-Release number of selected component (if applicable):
clusterssh-3.19.1-2.fc6
kdebase-3.5.5-0.4.fc6

How reproducible:
Sometimes. Not always, but often enough to reproduce it quickly.

Steps to Reproduce:
1. open cssh sessions to two hosts
2. move the X-term windows to desired screen positions, e.g. one left, one right
3. switch to other desktop (screen) and back several times
  
Actual results:
X-term window position changed

Expected results:
Windows should remain in the original screen position

Comment 1 Duncan Ferguson 2007-02-05 19:29:34 UTC
This is known problem and is due to the perl/TK libraries not differentiating 
between a minimize/maximise event and a virtual desktop switch event.

I will recheck perl/Tk to see if this has changed recently.

  Duncs


Note You need to log in before you can comment on or make changes to this bug.