Bug 227356 - read only mount allowed in %pre/%post sections of kicjstart file
read only mount allowed in %pre/%post sections of kicjstart file
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-05 11:21 EST by Tom Kennedy
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-22 09:20:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the kickstart file. (1.98 KB, text/plain)
2007-02-06 12:25 EST, Tom Kennedy
no flags Details

  None (edit)
Description Tom Kennedy 2007-02-05 11:21:36 EST
Description of problem:

I have mount commands that are attempting to mount read/write file systems
during the %pre and %post phases of Linux installation.  When the instaler gets 
to these commands, a message saying the "the File system is Read Only" is 
printed.  I tried tp mount it manyally with the -rw options to mount, but it 
did not work.  The same commands work fine froma a RHEL4 installation, so I 
know the NFS mountse are OK.  

Version-Release number of selected component (if applicable):


How reproducible:

1) Add a mount command that mounts an NFS share read/write in the %pre or %post
sections of a kickstart file
   Add a command that echo text to a file on the mounted share
2) Start the installation

  
Actual results:

A message saying the mounted file system is Readonly is displayed

Expected results:

The file should be created with the echoed text.

Additional info:
Comment 1 Tom Kennedy 2007-02-05 18:02:02 EST
The title is a little misleading.   It should say  write to NFS shared not 
allowwed in %pre/%post kickstart sections.
Comment 2 Chris Lumens 2007-02-06 10:47:42 EST
What does your kickstart file look like?
Comment 3 Tom Kennedy 2007-02-06 12:25:41 EST
Created attachment 147494 [details]
This is the kickstart file.
Comment 4 Tom Kennedy 2007-02-16 12:08:16 EST
Solved.  Turns out one of the mounts did not have the -o nolock

Comment 5 Chris Lumens 2007-02-22 09:20:42 EST
Closing as NOTABUG on the basis of comment #4.  If you still continue to see
problems even after adding -o nolock, please feel free to reopen this bug report.

Note You need to log in before you can comment on or make changes to this bug.