Bug 2273828 - Plasma System Monitor crashes with segmentation fault
Summary: Plasma System Monitor crashes with segmentation fault
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-systemmonitor
Version: 40
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jan Grulich
QA Contact:
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F40FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2024-04-07 03:28 UTC by Geraldo Simião
Modified: 2024-04-08 00:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-04-08 00:12:38 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Geraldo Simião 2024-04-07 03:28:54 UTC
This is for tracking purposes, see https://bugs.kde.org/show_bug.cgi?id=484919 and https://bugs.kde.org/show_bug.cgi?id=482169 for the upstream reports.

Reproducible: Always

Confirmed on:
plasma-systemmonitor-6.0.3-1.fc40

0::/user.slice/user-1000.slice/user/app.slice/app-org.kde.plasma\x2dsystemmonitor-10da3a4ffad14ebeb24b62453b96eaba.scope

Operating System: Fedora Linux 40
KDE Plasma Version: 6.0.3
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.2
Kernel Version: 6.8.4-300.fc40.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-3632QM CPU @ 2.20GHz
Memory: 15.4 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 4000
Manufacturer: Acer
Product Name: Aspire V3-571

Reproducible: Always

Comment 1 Fedora Blocker Bugs Application 2024-04-07 03:31:29 UTC
Proposed as a Blocker for 40-final by Fedora user geraldosimiao using the blocker tracking app because:

 System monitor crashing on clicking "Show Details Sidebar" seems to violates the default application criterion.

Comment 2 Geraldo Simião 2024-04-07 03:32:49 UTC
Being dicussed on kde dicussion too: https://discuss.kde.org/t/system-monitor-reproducibly-crashes-but-drkonqi-never-notices/12584

Comment 3 Fedora Update System 2024-04-07 08:59:35 UTC
FEDORA-2024-0fb5895755 (qt6-qtdeclarative-6.6.2-3.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-0fb5895755

Comment 4 Adam Williamson 2024-04-07 14:56:22 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/1571 , marking accepted.

Comment 5 Fedora Update System 2024-04-08 00:12:38 UTC
FEDORA-2024-0fb5895755 (qt6-qtdeclarative-6.6.2-3.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.