Bug 2274215 - OSError: container failed to start -> lxc-libs not installed
Summary: OSError: container failed to start -> lxc-libs not installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lxc
Version: 40
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Sergio Basto
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-04-09 18:38 UTC by Geraldo Simião
Modified: 2024-04-19 21:33 UTC (History)
6 users (show)

Fixed In Version: lxc-5.0.3-2.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-04-19 21:33:50 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
waydroid log (3.57 KB, text/plain)
2024-04-09 18:41 UTC, Geraldo Simião
no flags Details

Description Geraldo Simião 2024-04-09 18:38:27 UTC
Today I installed waydroid on F40 KDE to test it.

Running sudo dnf in waydroid it installed:
    Instalar libgbinder-1.1.36-1.fc40.x86_64      @fedora
    Instalar libglibutil-1.0.76-1.fc40.x86_64     @fedora
    Instalar lxc-5.0.3-1.fc40.x86_64              @fedora
    Instalar python3-gbinder-1.1.2-4.fc40.x86_64  @fedora
    Instalar python3-pyclip-0.7.0-6.fc40.noarch   @fedora
    Instalar waydroid-1.4.2-3.fc40.noarch         @fedora
    Instalar waydroid-selinux-1.4.2-3.fc40.noarch @fedora
    Instalar wl-clipboard-2.2.1-2.fc40.x86_64     @fedora

It created the systemd symlink correctly and the service started fine after a reboot. I Managed to run the waydroid wizard and donwloaded succesfully the ota files, both. After that I tryed to start a session but it allways returned OSError: container failed to start (waydroid log is attached).

I showed a friend and it asked me to install the package lxc-libs so I did it and installed lxc-libs-5.0.3-1.fc40.x86_64.

After that I managed to start a waydroid session, and all apps showed on the plasma start menu.

My question: doesn't lxc-libs be a dependency sommehow from waidroid too?





Reproducible: Always

Steps to Reproduce:
1.Install waydroid (sudo dnf in waydroid)
2.run the wizard
3.try to start a session (waydroid session start)
Actual Results:  
ERROR MESSAGE: OSError: container failed to start

Expected Results:  
MESSAGE: Android with user 0 is ready
And working waydroid session and apps.

After install from lxc-libs-5.0.3-1.fc40.x86_64 all is working as expected.

Operating System: Fedora Linux 40
KDE Plasma Version: 6.0.3
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.2
Kernel Version: 6.8.4-300.fc40.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-3632QM CPU @ 2.20GHz
Memory: 15.4 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 4000
Manufacturer: Acer

Comment 1 Geraldo Simião 2024-04-09 18:41:16 UTC
Created attachment 2026014 [details]
waydroid log

Comment 2 Geraldo Simião 2024-04-09 20:18:58 UTC
changed component to lxc since it is a lxc packaging thing

Comment 3 Sergio Basto 2024-04-09 23:08:26 UTC
as reported on matrix #pt-br:fedoraproject.org the problem is lxc doesn't require lxc-libs as in previous lxc-4.x.x versions .

Comment 4 Fedora Update System 2024-04-10 03:26:56 UTC
FEDORA-2024-c19cc734fc (lxc-5.0.3-2.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-c19cc734fc

Comment 5 Geraldo Simião 2024-04-10 23:55:48 UTC
Update works fine.

Comment 6 Fedora Update System 2024-04-11 00:55:25 UTC
FEDORA-2024-c19cc734fc has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-c19cc734fc`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-c19cc734fc

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2024-04-19 21:33:50 UTC
FEDORA-2024-c19cc734fc (lxc-5.0.3-2.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.