Bug 22744 - Dos won't boot after install 7.0
Dos won't boot after install 7.0
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-22 10:07 EST by Jim Langston
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Langston 2000-12-22 10:07:50 EST
After installing Windows 98, checking system, everything is fine. After
installing 7.0, everything with 7.0 works, boots fine. But, when trying
to boot Windows, nothing happens and freezes with disk spinning. Unable
to boot Windows with floppy or CD. Deleted the Linux partitions via expert
mode using fdisk. Windows comes up just fine.

LILO - writes to disk and can get graphical interface for changing OS,
       linux or dos. 

I did fdisk /mbr to get back to a clean mbr, then re-installed 7.0 again.
Same issue.

System:
	E6557 - Fujitsu 
		192MB
		1 internal drive - 15GB

	Windows on c: w/7.5G partition
	Linux - everything else
Comment 1 Sean McPherson 2000-12-23 21:06:30 EST
What does the partition table look like (in effect, is the DOS 
partition /dev/hda1 or somewhere else, and are all the linux partitions 
primary, or logocals in an extended, etc)?
Comment 2 Jim Langston 2000-12-26 08:23:31 EST
I have 1 15G disk, the first partition is win98, which I created 
at 7.5G (to stay under 1024). fdisk (linux) shows the /dev/hda1 to
be a msdos partition. After that I created /boot swap and / with the
rest of the disk. When it didn't boot win98, I reloaded and then created
/boot swap /usr /home /, but was still unable to boot win98. LILO created the
graphical login.

I was unable to boot win98 off CD, so I'm not sure if Linux is in an extended
partition.
Comment 3 Need Real Name 2001-01-03 17:36:28 EST
I have a similar situation. I have my win98 partition on /dev/hdb1 (primary, 
pre-1024th cyl) & my all linux paritions /dev/hda.
I can't seem to boot windows no matter where i put it(ie. i copied it to an 
extended  /dev/hda partition & configured it & tried to boot & it it hangs at 
the Loading dos screen.

device info:
/dev/hda :: 45gig IBM UATA/100 7200
/dev/hdb :: 8.4gig IBM UATA/33 5400

mobo: post 1998 (gateway/intel 440BX/ 400Mhz)

is there some special way to boot windows other than
----------------
other=/dev/hdb1
lable=dos
/sbin/lilo
----------------
??
is there a limit on the size of the windows partition it can boot?

i've tried:
compact & linear
compact & lba32
just linear
just lba32
ALL WITH THE SAME RESULTS(hanging at LILO)

Comment 4 Jeremy Katz 2002-06-04 02:08:45 EDT
Does this work better in more recent releases?
Comment 5 Jeremy Katz 2002-06-29 17:47:32 EDT
Closing due to inactivity.  If you have further information, please reopen this bug.
Comment 6 Red Hat Bugzilla 2006-02-21 13:47:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.