Bug 227455 - slapi_search_internal_get_entry returns incorrect error code
slapi_search_internal_get_entry returns incorrect error code
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
All Linux
low Severity low
: rc
: 7.3
Assigned To: Noriko Hosoi
Viktor Ashirov
:
Depends On:
Blocks: 389_1.3.0 512820
  Show dependency treegraph
 
Reported: 2007-02-05 19:14 EST by Bob Lord
Modified: 2017-03-09 11:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-09 11:52:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Rowley 2007-02-05 19:14:26 EST
Description of problem:

If a plugin has failed to add its plugin id, instead using zero, the error code
returned is "no such object" when it should be "access denied" - it could also
be a bit more vocal in debug mode to alert the programmer that the failure is
due to plugin level authentication.  

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Martin Kosek 2012-01-04 08:47:16 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/134

Note You need to log in before you can comment on or make changes to this bug.