Bug 227463 - 2.6.18-1.2257.fc5xenU fails to boot
2.6.18-1.2257.fc5xenU fails to boot
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Mark McLoughlin
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2007-02-05 23:48 EST by Ben
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.20-1.2307.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-04-02 06:40:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ben 2007-02-05 23:48:17 EST
Description of problem:

2.6.18-1.2257.fc5xenU doesn't boot, presumably because of this message in the
boot log:

mount: could not find filesystem '/dev/root'

Version-Release number of selected component (if applicable):

Going to boot Fedora Core (2.6.18-1.2257.fc5xenU)
  kernel: /vmlinuz-2.6.18-1.2257.fc5xenU
  initrd: /initrd-2.6.18-1.2257.fc5xenU.img

How reproducible:

Always, on multiple domU machines.

Steps to Reproduce:
1. yum update to 2.6.18-1.2257.fc5xenU
2. boot domU
3. observe failure to create /dev/root
Actual results:

Some of the boot log:

Using config file "/etc/xen/cashnet".
Going to boot Fedora Core (2.6.18-1.2257.fc5xenU)
  kernel: /vmlinuz-2.6.18-1.2257.fc5xenU
  initrd: /initrd-2.6.18-1.2257.fc5xenU.img
Started domain cashnet
Bootdata ok (command line is  ro root=/dev/VolGroup00/LogVol00)
Linux version 2.6.18-1.2257.fc5xenU (brewbuilder@ls20-bc1-13.build.redhat.com)
(gcc version 4.1.1 20060525 (Red Hat 4.1.1-1)) #1 SMP Fri Dec 15 17:32:05 EST 2006
device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@redhat.com
Loading dm-mirror.ko module
Loading dm-zero.ko module
Loading dm-snapshot.ko module
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

Additional info:

2.6.18-1.2239.fc5xenU was the last in a long line of kernels to have worked
fine. Fortunately, I can roll back to 2.6.18-1.2239.fc5xenU without apparent
issue, but I haven't tried to upgrade anything in my dom0 yet.
Comment 1 Ben 2007-03-07 00:14:51 EST
FYI, this was fixed with 2.6.19-1.2288.2.4.fc5xenU.
Comment 2 Ben 2007-03-07 00:47:16 EST
....and, just for clarity, 2.6.19-1.2288.fc5xenU does *not* work. What's up with
the "2.4" part of the rpm?

Comment 3 Ben 2007-03-07 11:55:15 EST
Sorry, I have to take this back. While most hosts seem to work just fine with
2.6.19-1.2288.2.4.fc5xenU, I have a few that are still not able to mount /dev/root. 
Comment 5 Mark McLoughlin 2007-03-30 07:45:46 EDT
Is the latest kernel-xenU (2.6.20-1.2307.fc5) still broken ?

If so, what is the configuration of this domU? (i.e. /etc/xen/Foo)
Comment 6 Ben 2007-03-30 23:20:39 EDT
No, it seems 2.6.20-1.2307.fc5 fixes the problem. 
Comment 7 Mark McLoughlin 2007-04-02 06:40:47 EDT
Thanks Ben

Note You need to log in before you can comment on or make changes to this bug.