Bug 227479 - i9xx chipeset with sata and HDD password doesn't prompt for password on resume
i9xx chipeset with sata and HDD password doesn't prompt for password on resume
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-06 06:10 EST by Peter Robinson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: Fedora7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 08:34:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2007-02-06 06:10:34 EST
I have a Dell Latitude D620 which is a Centrino Duo with a i9xx chipset and a
sata disk using libata and Fedora Core 6. The machine suspends and resumes fine
when there isn't a HDD password set. Our corporate laptop usage policy requires
all laptops to have a HDD password set. 

When a HDD password is set the machine suspends fine but on resume it doesn't
properly come back. X comes up with a blank screen and if you switch to a
console it just starts spewing libata disk errors. It should initially display
the BIOS screen and prompt for the password. It did this fine on my old laptop
which was a Dell Latitude D600 running Fedora Core 5. I've never run FC5 on this
laptop, nor FC6 on the old one so not sure if its due to move from PATA/ide to
SATA/libata or a kernel bug or something else.
Comment 1 Peter Robinson 2007-09-24 08:34:48 EDT
Seems to be fixed in Fedora 7 + recent updates.

Note You need to log in before you can comment on or make changes to this bug.