Bug 22748 - installer hangs on Promise ATA100 controller
Summary: installer hangs on Promise ATA100 controller
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard: Florence Beta-3
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-22 19:06 UTC by David Lawrence
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-11 21:13:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Lawrence 2000-12-22 19:06:09 UTC
In the test lab we have an Asus SV7 motherboard that has an onboard Promise
ATA100 controller chip. The motherboard has 2 standard IDE slots and 2
Promise slots. connected to the primary Promise slot was a Maxtor 40GB
ATA66 IDE drive. The Promise bios screen properly detects the hard disk.
During the first stage installer when the newt window comes up showing
Loading IDE modules... the machine hard freezes and has to be reset. With
the same configuration except with the maxtor drive plugged into the
standard IDE port, it continues on with the install properly. Note: Promise
controller states no BIOS support is installed when it does not detect any
drives connected to it. I will try it with a drive connected to the primary
of both the standard and Promise interfaces. Although I suspect the same
thing will happen.

Comment 1 Michael Fulbright 2000-12-27 17:04:52 UTC
I've seen the same behavior. What is even more strange is if you install a
system w/o the drive attached to the ATA100 port, and then reboot it with the
drive attached to the ATA100 port, you can go an format it, etc.

Something about the order modules are installed perhaps? Most definately a
kernel problem.



Comment 2 Michael Fulbright 2000-12-27 17:05:46 UTC
The system I can reproduce this on has a Asus A7V board with a 750MHZ Duron.

The drive is a 20GB Seagate ATA II Barracuda.

Comment 3 Glen Foster 2001-01-11 21:13:09 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 4 Michael K. Johnson 2001-01-12 14:24:34 UTC
Should be resolved by reverting modular IDE to static IDE.
Turns out there are geometry problems with modular IDE...


Note You need to log in before you can comment on or make changes to this bug.