Bug 2274830 - Reinstate network service for Fedora 40
Summary: Reinstate network service for Fedora 40
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 40
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jan Macku
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: Accepted0Day
Depends On:
Blocks: F40FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2024-04-13 00:57 UTC by Adam Williamson
Modified: 2024-05-14 12:57 UTC (History)
7 users (show)

Fixed In Version: initscripts-10.23-1.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-05-14 12:57:32 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github fedora-sysv initscripts pull 480 0 None open fix: return support for network-scripts for Fedora 40 2024-04-16 08:10:37 UTC

Description Adam Williamson 2024-04-13 00:57:55 UTC
initscripts 10.21-1.fc40 dropped the legacy 'network' service. This was done with no communication and no Change proposal. This is a significant interface that folks are definitely still using - exhibit A, I use it in fedora infrastructure for the openQA worker hosts because there is integration between the legacy network scripts and openvswitch, see below config:

https://pagure.io/fedora-infra/ansible/blob/main/f/roles/openqa/worker/templates/ifcfg-tap.j2
https://pagure.io/fedora-infra/ansible/blob/main/f/roles/openqa/worker/files/ifcfg-br0

also, the network service allows the use of special scripts at certain points, like this one:

https://pagure.io/fedora-infra/ansible/blob/main/f/roles/openqa/worker/files/ifup-pre-local

which I use to pre-create the tap devices for tap interfaces.

I believe removal of this interface, even though it was in some ways marked as deprecated, is a significant change which should have gone through the Change process to create greater awareness, allow people to raise unconsidered use cases like mine, and ensure the change is properly documented. Thus I'm nominating this bug as a blocker not via the usual process (it doesn't technically violate any release criteria), but to ask FESCo to designate it as a blocker as violation of the Change process. I believe the service should be reinstated for F40. If removal is desired, a Change should be filed for F41.

Comment 1 Zbigniew Jędrzejewski-Szmek 2024-04-13 14:33:53 UTC
It seems to be a downstream change, not a change in the upstream, so it seems doable to reverse this.

@jamacku?

Comment 2 Zbigniew Jędrzejewski-Szmek 2024-04-15 20:33:38 UTC
https://src.fedoraproject.org/rpms/initscripts/pull-request/10 restores the subpackage.
I don't know enough about the package to be confident enough to push an update,
so just a PR.

Comment 3 Jan Macku 2024-04-16 07:53:35 UTC
I'm sorry for the inconvenience caused by removing network-scripts support from Fedora 40.

We didn't accept the change proposal because we were in a hurry and were confident that network-scripts were no longer used.

I'll prepare a new update with network-scripts support and will work on a proposal for Fedora 41.

Comment 4 Fedora Update System 2024-04-16 10:40:12 UTC
FEDORA-2024-bf57c83e79 (initscripts-10.23-1.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-bf57c83e79

Comment 5 Adam Williamson 2024-04-16 15:48:10 UTC
From https://meetbot-raw.fedoraproject.org/teams/fesco/fesco.2024-04-15-19.01.html :

* "AGREED: proposal: FESCo asks that the legacy network subpackage be reinstated for F40. The bug requesting the reinstatement is marked as F40-0day and F40-freeze-exception. APPROVED(+7,0,0)"
* "AGREED: Proposal: the network-scripts should block F40 GA. REJECTED(+1,0,-6)"

so, FESCo voted that this should be Accepted0Day, which means the fix does not need to be included in the RC compose or the frozen release repo (so there will be no network-scripts package in the frozen release repo) but must be pushed stable before the release day (so there will always be a network-scripts package in the F40 updates repo).

Comment 6 Fedora Update System 2024-04-17 01:55:42 UTC
FEDORA-2024-bf57c83e79 has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-bf57c83e79`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-bf57c83e79

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2024-04-19 21:36:13 UTC
FEDORA-2024-bf57c83e79 (initscripts-10.23-1.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.