Bug 2275290 - memory leak in aarch64 beginning with kernel 6.8.4
Summary: memory leak in aarch64 beginning with kernel 6.8.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 39
Hardware: aarch64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2279327 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-04-16 14:01 UTC by Thomas Clark
Modified: 2024-05-10 02:59 UTC (History)
18 users (show)

Fixed In Version: kernel-6.8.9-200.fc39 kernel-6.8.9-300.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-05-03 12:15:25 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Thomas Clark 2024-04-16 14:01:35 UTC
1. Please describe the problem:

Beginning with kernel 6.8.4 and continuing with 6.8.5, there is a memory leak on my Rasberry Pi with 8 GB of RAM. This device is running freeipa and almost nothing else. It is stable on kernel 6.7.11. On any 6.8 kernel, memory is depleted over a period of 1-2 days to the point that OOM kills everything up to and including systemd. I have confirmed that the memory is not consumed by any user space application.

2. What is the Version-Release number of the kernel:

Any 6.8.x kernel

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

There is no memory leak in 6.7.11.  The issue first appeared in 6.8.4.


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

It is reproducible 100% of the time just by booting a 6.8.4 or 6.8.5 kernel.

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:


6. Are you running any modules that not shipped with directly Fedora's kernel?:

No


7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

There is nothing relevant in the logs.

Reproducible: Always

Comment 1 Paul Black 2024-04-23 15:43:54 UTC
I'm seeing the same on a Pi3 v1.3 running Fedora 40 IoT. I've put 6.8.7 on it to make it more similar to my other devices. It seems to fall over after about 11-12 hours. This device is mostly always idle until called upon to run the occaissional build test.

I have two more Pi3 (one v1.2, one v1.3) running a more "standard" Fedora 40 with 6.8.7 which don't exhibit the problem. These two have something running continuously although they're not heavily loaded.

I'm still trying to identify where the memory is going but kmalloc-4k in slabtop appears to be the difference (only managed a few hours of comparison).

Comment 2 Thomas Clark 2024-04-24 02:30:27 UTC
Still present on 6.8.7-200.fc39.aarch64.  It lasted about 12 hours before running through the 8 GB of RAM. I also haven't figured out where it's going. It's not user space.

Comment 3 Paul Black 2024-05-03 08:18:42 UTC
First impressions are that this is fixed in 6.8.9

Comment 4 Justin M. Forbes 2024-05-03 12:15:25 UTC
Yes, there was a fix for this that made it into 6.8.9

Comment 5 Fedora Update System 2024-05-03 12:19:20 UTC
FEDORA-2024-3697e3b459 (kernel-6.8.9-200.fc39) has been submitted as an update to Fedora 39.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-3697e3b459

Comment 6 Fedora Update System 2024-05-03 12:20:19 UTC
FEDORA-2024-c90afc5c01 (kernel-6.8.9-300.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-c90afc5c01

Comment 7 Fedora Update System 2024-05-04 03:17:37 UTC
FEDORA-2024-3697e3b459 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-3697e3b459`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-3697e3b459

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2024-05-04 03:37:52 UTC
FEDORA-2024-c90afc5c01 has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-c90afc5c01`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-c90afc5c01

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Thomas Clark 2024-05-04 19:18:47 UTC
The memory leak is resolved.

Comment 10 wolf 2024-05-09 16:14:52 UTC
*** Bug 2279327 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2024-05-10 01:05:13 UTC
FEDORA-2024-3697e3b459 (kernel-6.8.9-200.fc39) has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2024-05-10 02:59:12 UTC
FEDORA-2024-c90afc5c01 (kernel-6.8.9-300.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.