Bug 227577 - RFE: time zone (CRON_TZ) support
RFE: time zone (CRON_TZ) support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Brock Organ
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-06 17:12 EST by Joel Uckelman
Modified: 2008-07-23 06:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 06:49:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Uckelman 2007-02-06 17:12:07 EST
Description of problem:

Vixie cron on NetBSD supports a variable called CRON_TZ, which a user can put
into his crontab to cron what time zone the listed times are in. Among other
things, this variable saves people who live in areas which use Daylight Savings
Time from having to adjust the times in their crontabs twice per year. Since
this is already present in another version of Vixie cron, I imagine it would be
relatively easy to port it to the version that Fedora uses.

Version-Release number of selected component (if applicable):

vixie-cron-4.1-64.fc6
Comment 1 Marcela Mašláňová 2007-02-07 08:43:24 EST
Some daylight saving is solved by cron see: man 8 cron, but you're right. It
could be useful. I'll investigate about it.
Comment 2 Marcela Mašláňová 2007-04-10 09:12:28 EDT
Daylight saving has been implemented in your version of cron. If you have some
problem with daylight saving, which could be reproduce, please feel free to
reopen this bug.
Comment 3 Joel Uckelman 2007-04-16 08:11:31 EDT
The problem is not with DST per se. Rather, it's a problem for users who use a
time zone different from the one the server uses. For example, I have a server
in Tuscon, Arizona, USA. The state of Arizona doesn't use DST, i.e. it is always
GMT-7 there. I'm in Amsterdam, which is GMT+2 from March to October and GMT+1
during the rest of the year. This means that anything I put into my crontab to
run, say, at noon everyday in Tuscon is going to run at two different hours for
me in Amsterdam, depending on the time of year. Conversely, it is impossible for
me to schedule a process which will occur at the same time (for me) year round.
Instead, I have to manually adjust the time in my crontab twice a year.

This problem will occur for any combination of user and server where the
difference between the user's and server's time zones does not remain constant
year round. E.g., Europe doesn't switch to and from DST at the same time as the
parts of North America which use DST, so it's not just a problem for people like
me who have servers in Arizona.

Implementing the CRON_TZ variable would entirely solve this problem, as then
each user could tell cron what time zone should be used for interpreting his 
crontab.

For a description of how CRON_TZ works in NetBSD, see here:

http://netbsd.gw.com/cgi-bin/man-cgi?crontab+5+NetBSD-current
Comment 4 Marcela Mašláňová 2007-11-12 06:49:34 EST
Thanks for explanation. Now is the patch working for me, I'll push it to
development version. Hope that solution would be fine for you either.

Comment 5 Joel Uckelman 2008-07-23 06:12:09 EDT
Thanks for implementing this!

Note You need to log in before you can comment on or make changes to this bug.