Bug 227686 - activation/entitlement service requires Product Code
Summary: activation/entitlement service requires Product Code
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Web Site
Classification: Red Hat
Component: Product_Activation   
(Show other bugs)
Version: web230
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bryan Kearney
QA Contact: Web Development
URL: http://www.webqa.redhat.com/wapps/act...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-07 15:59 UTC by joseph canton
Modified: 2011-05-24 06:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-12 13:19:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description joseph canton 2007-02-07 15:59:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061215 Red Hat/1.5.0.9-0.1.el4 Firefox/1.5.0.9

Description of problem:
Current implementation of Activation/Entitlement Service requires that an Installation number be generated for every activated product.  This means every product must have a Product Code of 0,1, or 3.  This bugzilla is opened as a placeholder or reminder that this data migratio must happen prior to WEB230 or alternatively the Entitlement service must be hacked.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Unable to reproduct this min as QA is down, but in general, try to
activate any sku that has no product code, like MCT0402RN or MCT0900 or MCT0971
2.
3.

Actual Results:


Expected Results:


Additional info:
This ticket is a placeholder so this item is not forgotten. Please update this ticket with resolution.

Comment 1 Mark Sechrest 2007-02-08 15:09:29 UTC
Good catch! This was overlooked in the planning for 230. Bryan Kearney will get
a list of the skus in the hock tables, and provide to Matt Webbink. Matt will
update those skus in Prod, prior to the 230 release.

Comment 2 Mark Sechrest 2007-02-12 13:18:00 UTC
Matt Webbink indicates this data has been entered in production. Closing.

Comment 3 Mark Sechrest 2007-02-12 13:19:07 UTC
Closing as NOTABUG because this was really a reminder to complete some data
entry in prod before we push live.


Note You need to log in before you can comment on or make changes to this bug.