Bug 227734 - LiveCD: "Cannot create root file system!"
LiveCD: "Cannot create root file system!"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
David Lawrence
http://img374.imageshack.us/img374/78...
:
: 230828 (view as bug list)
Depends On:
Blocks: Fedora7LiveCD
  Show dependency treegraph
 
Reported: 2007-02-07 15:50 EST by Philipp N.
Modified: 2013-03-05 22:49 EST (History)
10 users (show)

See Also:
Fixed In Version: test2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-20 16:41:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of error on F7 test 2 Live CD (56.62 KB, image/jpeg)
2007-03-05 15:53 EST, Richard Körber
no flags Details
Error messages returned by test2 livecd, before the warning (2.44 KB, text/plain)
2007-03-06 02:40 EST, Saverio
no flags Details
Errors after invoking vol_id (56.94 KB, image/jpeg)
2007-03-20 16:23 EDT, Richard Körber
no flags Details

  None (edit)
Description Philipp N. 2007-02-07 15:50:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.8.0.9) Gecko/20070131 Fedora/1.5.0.9-2.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
Well I just booted the LiveCD and then this error is on the screen:

WARNING: Cannot create root file system!
http://img374.imageshack.us/img374/7828/rimg0172ax6.jpg (Screenshot)

I tried both boot parameters (the 1GB+ one and without - I have 1GB RAM "-" 128MB for the graphic card), but nothing changed.
And of course I checked the sha-sum and it was the same I found on the ftp-server!

Version-Release number of selected component (if applicable):
fc7test1

How reproducible:
Always


Steps to Reproduce:
1. Boot the LiveCD
2. Wait

Actual Results:
http://img374.imageshack.us/img374/7828/rimg0172ax6.jpg
This screen...

Expected Results:
Fedora "Live"

Additional info:
Comment 1 Guido Ledermann 2007-02-10 15:47:55 EST
Same here. Maybe it has something to do, that I only have SATA disks in use?
Comment 2 Sebastian Vahl 2007-02-28 15:03:48 EST
Same problem (no /dev/root) here with F7test1 on two machines:

1. http://smolt.fedoraproject.org/show?UUID=e689326b-2c7d-4fbc-969e-f6293086ab97
2. http://smolt.fedoraproject.org/show?UUID=2e386ff4-8c36-4017-bae0-deab54df7e77

Also a self created livecd with livecd-tools based on todays rawhide stopped at
the same point. The rawhide installation itself boots fine.

Not sure if its relevant: I've also extracted the livecd-initramfs.img from the
live-cd. There ist no pata_via and ata_generic. When the boot stops the only
loaded modules are: ehci_hdc and uhci_hcd.
Comment 3 Jeremy Katz 2007-03-01 14:21:26 EST
test2 should be a lot better here.  We were missing a few (important) modules
due to typos in the module list.

Can you try again with test2?
Comment 4 Sebastian Vahl 2007-03-01 14:30:13 EST
(In reply to comment #3)

> Can you try again with test2?

On my hardware test2 is booting fine.

Comment 5 Richard Körber 2007-03-01 16:57:11 EST
Both F7 test 1 and F7 test 2 Live CDs are failing on my machine. :(
Comment 6 Bill Nottingham 2007-03-02 12:29:33 EST
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.
Comment 7 Philipp N. 2007-03-02 16:41:36 EST
(In reply to comment #3)
> Can you try again with test2?

Sure! And now it works fine on my machine (too).

(In reply to comment #5)
> Both F7 test 1 and F7 test 2 Live CDs are failing on my machine. :(

Is it exactly the same error? It seems to me, that the bug is fixed with test2
(in regard with my experiences and Mr. Vahl's)...
Comment 8 Luya Tshimbalanga 2007-03-03 04:07:27 EST
*** Bug 230828 has been marked as a duplicate of this bug. ***
Comment 9 Richard Körber 2007-03-05 15:52:36 EST
It is exactly the same error. I will attach a screenshot.

The machine is:
http://smolt.fedoraproject.org/show?UUID=db8555c4-4b6b-4a6f-a7ea-79aeb1278dc6
Comment 10 Richard Körber 2007-03-05 15:53:55 EST
Created attachment 149292 [details]
Screenshot of error on F7 test 2 Live CD
Comment 11 Saverio 2007-03-06 02:07:01 EST
Same error on my machine, both with test 1 and with test 2
http://smolt.fedoraproject.org//show?UUID=9147f5d7-edfc-4494-95e9-0a5f1e831296
Comment 12 Saverio 2007-03-06 02:40:37 EST
Created attachment 149324 [details]
Error messages returned by test2 livecd, before the warning

I just realized that test2 version of the livecd returns something before the
warning. Hope it helps.
Again, the machine is
http://smolt.fedoraproject.org//show?UUID=9147f5d7-edfc-4494-95e9-0a5f1e831296
Comment 13 Jeremy Katz 2007-03-20 11:28:25 EDT
For the cases which are still failing, can you look in /sys/block when you get
dropped into the shell and see what's there?  Also, what's in /proc/modules?
Comment 14 Richard Körber 2007-03-20 15:18:33 EDT
# ls /sys/block
ram0 ram10 ram12 ram14 ram2 ram4 ram6 ram8 sda
ram1 ram11 ram13 ram15 ram3 ram5 ram7 ram9 sr0

# cat /proc/modules
sr_mod 20581 0 - Live 0xce8b4000
cdrom 36961 1 sr_mod, Live 0xce8c0000
sd_mod 24513 0 - Live 0xce89e000
ehci_hcd 36185 0 - Live 0xce8aa000
ohci_hcd 25185 0 - Live 0xce84a000
uhci_hcd 27609 0 - Live 0xce835000
ata_piix 19141 0 - Live 0xce819000
ata_generic 12101 0 - Live 0xce831000
libata 112869 2 ata_piix,ata_generic, Live 0xce881000
scsi_mod 141101 3 sr_mod,sd_mod,libata, Live 0xce85d000
Comment 15 Jeremy Katz 2007-03-20 15:56:32 EDT
(In reply to comment #14)

Hmmm, so that looks like the block device is there and getting found.  What's
the output of /lib/udev/vol_id -l /dev/sr0?
Comment 16 Richard Körber 2007-03-20 16:18:44 EDT
Well... I can ls the /dev/sr0. But when I invoke the vol_id command, I am
getting an endless (I assume) output of "ata2.00: qc timeout" errors. I just
turned off the power after a couple of minutes since there seemed to be no
ending and also no way to abort it.

A screenshot will follow...
Comment 17 Richard Körber 2007-03-20 16:23:27 EDT
Created attachment 150530 [details]
Errors after invoking vol_id
Comment 18 Saverio 2007-03-20 16:25:42 EDT
(In reply to comment #13)
> For the cases which are still failing, can you look in /sys/block when you get
> dropped into the shell and see what's there?  Also, what's in /proc/modules?


In my /sys/block I have
ram0 ram10 ram12 ram14 ram2 ram4 ram6 ram8
ram1 ram11 ram13 ram15 ram3 ram5 ram7 ram9

and after this output it start a sequence of "ata2: port failed to respond"
messages (this time endless, I have to reboot). I tried to list the content of
/proc/modules but the sequence of error message started as soon as I tried to cd
to /proc.
I'll try again and post the results.
Comment 19 Jeremy Katz 2007-03-20 16:41:22 EDT
Okay -- Saverio and Richard, your problems both look like problems with the
kernel recognizing and working (respectively) with your CD drives.

I hate asking this, but can you file separate bugs against the kernel so that
they can be tracked properly.  You've got different hardware and slightly
different symptoms and so it would be a lot easier if we could track them
individually.

Closing this out as the original reporter's bug has been resolved
Comment 20 Richard Körber 2007-03-20 17:05:00 EDT
For reference: I have opened Bug 233202. Thanks for your help, Jeremy.

Note You need to log in before you can comment on or make changes to this bug.