Bug 227756 - spamassassin needs restart only if sa-update returns 0
Summary: spamassassin needs restart only if sa-update returns 0
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-07 22:35 UTC by Milan Kerslager
Modified: 2008-03-16 01:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-16 01:17:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Milan Kerslager 2007-02-07 22:35:13 UTC
sa-update returns 1 if there is no update available
sa-update returns 0 if update has been succesfull

Please change /usr/share/spamassassin/sa-update.cron to not restart spamassassin
when there is no change in the updated rules.

Comment 1 Warren Togami 2007-02-07 22:43:18 UTC
Nice catch, adding this to the package...

Comment 2 Warren Togami 2007-02-07 22:47:38 UTC
Please double-check me... sa-update.cronscript now reads:
#!/bin/bash

sleep $(expr $RANDOM % 7200)
echo SpamAssassin rule update begins at `date`
# Only restart spamd if sa-update returns 0, meaning it updated the rules
/usr/bin/sa-update && /etc/init.d/spamassassin condrestart
echo


Comment 3 Milan Kerslager 2007-02-07 23:24:11 UTC
This seems to be correct.

Comment 4 Kevin Fenzi 2008-03-16 01:17:04 UTC
Can this be closed now? This looks to have been updated long ago... 

Feel free to file a new bug, or re-open if you see any further issues. 


Note You need to log in before you can comment on or make changes to this bug.