Bug 227800 - [Indic] text moves when selected in kate
[Indic] text moves when selected in kate
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
bzcl34nup
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-08 04:29 EST by Amitakhya Phukan
Modified: 2008-08-04 19:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 19:56:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amitakhya Phukan 2007-02-08 04:29:45 EST
Description of problem:

A strange problem I have found in applications like kate/kedit. Opening any
"Indic" file and trying to select some portion causes the text to " move ".

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Open any document having some text written in any Indic language, I did with
Assamese.
2. Try to select a portion of the text.
3.
  
Actual results:

While selecting with the mouse, the text moves. Apart from that, if I want to
bring my cursor to a certain place within the Indic text, without the help of
cursor keys and just clicking on the relevant place with the mouse, the cursor
actually appears to be at some distance from the intended place.

Expected results:

Hopefully, it shouldn't happen!

Additional info:

Checked with other languages like Hindi and Gujarati. It is very difficult to
take a screenshot of the moving text or the cursor position, so will try to
provide later.
Comment 1 Amitakhya Phukan 2007-02-08 04:31:02 EST
Don't know if this bug has been reported earlier.
Comment 2 Amitakhya Phukan 2007-02-08 06:43:08 EST
Don't know if this bug has been reported earlier.
Comment 3 Sachin Tawniya 2007-02-20 00:11:12 EST
Well, It is right, the above thing happens in kate only and not in other k based
application. Kedit and other K based apps seems to be fixed which earlier having
the same kind of issue. As far as what I studied over this bug and working of
the kate is as 
Kate follows a tool from kdelibs i.e. katerenderer which calculates the width of
the inputed characters. Now a days conjucts are calcuated and treated as cluster
I mean combined word, so returns the width of the same, but never allows cursor
to be moved in betn. That is if you write 'U+09F1 + U+09BE' it is Ra + AA in
Assamese. Kate allows you to move cursor seperatly in 'Ra' as well as in 'AA'
also. Hence it calculate the width of these characters individually, it usually
do mistake while selection and painting them on the screen.

So in kate the combining the conjuncts and returning the same, is still missing.

please correct me if I am wrong.
regards,
Sachin Tawniya
Comment 4 Rex Dieter 2007-11-17 16:46:22 EST
Anyone try reporting this to upstream kde @ bugs.kde.org yet?  If not, that
would likely be the course that has the best chance of getting the issue
recognized/fixed by kde developers.
Comment 5 Bug Zapper 2008-04-03 15:03:44 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 6 Amitakhya Phukan 2008-04-04 02:24:31 EDT
hi all!

i have an updated Fedora 8 box with me now. I confirm that the problem exists
with kwrite and kate. the problem doesn't arise when we type only consonants.
however, if we type consonant+vowel_sign or any consonant-consonant combination,
then the cursor ends up at a place away from the characters typed. when we try
to select a portion of the text, we can see the text characters moving.

i am writing a few characters. please copy and paste them in kate or kwrite and
you can see the differences.

1. Only consonants : কখগঘঙচছজঝঞ
please note after you paste these characters and try to select a part or whole
of it, the selection through mouse/keyboard shows normal behaviour.

2. Consonant combinations with vowel signs and consonant-consonant combinations:
কাকীকিক্ৰচজাজীব্জ
the moment you paste these character combinations, you can see the cursor is
placed at a distance away from the last character typed. this creates problems
in navigating between words,specially if some correction is needed. also, when
you try to select part or whole of the word using mouse or keyboard, you can see
characters moving.
Comment 7 Jens Petersen 2008-05-01 02:46:03 EDT
This looks fixed with kde4: at least I can't reproduce with kwrite in pre-F9
rawhide.
Comment 8 Jens Petersen 2008-07-31 02:01:32 EDT
Amitakhya, could you confirm this is ok with KDE 4 in F9?
Comment 9 Amitakhya Phukan 2008-08-04 04:40:57 EDT
Hi,

Sorry for the delay from my side. Confirmed, it doesn't happen in Kate. I have just now updated my F9 box and tried it out. The problem doesn't exist.

Regards,
Amit.
Comment 10 Jens Petersen 2008-08-04 19:56:20 EDT
Thanks

Note You need to log in before you can comment on or make changes to this bug.