Bug 227858 - xen - man pages need reviewed for accuracy
xen - man pages need reviewed for accuracy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On: 225603
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-08 11:51 EST by Stephen Tweedie
Modified: 2008-05-21 11:19 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0305
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:19:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix incorrect xm create documentation (455 bytes, text/x-patch)
2008-01-17 10:36 EST, Richard W.M. Jones
no flags Details

  None (edit)
Comment 1 RHEL Product and Program Management 2007-03-21 18:06:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 RHEL Product and Program Management 2007-09-07 15:55:32 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 3 R P Herrold 2007-09-22 22:29:41 EDT
One clear staleness is this:

per the man page:

 without config file
                 xm create /dev/null ramdisk=initrd.img \
                    kernel=/boot/vmlinuz-2.6.12.6-xenU \
                    name=ramdisk nics=0 vcpus=1 \
                    memory=64 root=/dev/ram0

============================

running a variant of this:
[root@couch ~]#  xm create /dev/null
ramdisk=/var/ftp/pub/install/ftpinstall/images/pxeboot/initrd.img
kernel=/var/ftp/pub/install/ftpinstall/images/pxeboot/vmlinuz  name=ramdisk
nics=1 vcpus=1 memory=64 root=/dev/ram0
Using config file "/dev/null".
Warning: The nics option is deprecated.  Please use an empty vif entry instead:

  vif = [ '' ]

Error: (22, 'Invalid argument')
[root@couch ~]#     

returns a clear error in the page as to 'nics'.

==================================

continuing:

we get an error in the proposed config file suggested by the present man page:

[root@couch ~]#  xm create /dev/null
ramdisk=/var/ftp/pub/install/ftpinstall/images/pxeboot/initrd.img
kernel=/var/ftp/pub/install/ftpinstall/images/pxeboot/vmlinuz  name=ramdisk
vif='mac=00:16:3e:66:4c:d8,bridge=xenbr0'  vcpus=1 memory=64 root=/dev/ram0
Using config file "/dev/null".
Error: (22, 'Invalid argument')
[root@couch ~]#               

Error 22 -- Invalid Argement implies some error, but there is NO WAY clear from
the man page to diagnose it.  any thoughts?
Comment 4 Richard W.M. Jones 2008-01-17 08:15:04 EST
Just an update to this:

(1) The FIXMEs in the xm man page are gone (fixed in RHEL 5.1
when we updated the Xen userspace).

(2) The 'xm create' documentation is still wrong.  I'm preparing
a patch for this right now.
Comment 5 Richard W.M. Jones 2008-01-17 10:20:58 EST
and (3) I can't reproduce the 'Error 22 -- Invalid Argument'.  The following
command works just fine for me under RHEL 5.1:

/usr/sbin/xm create /dev/null \
  ramdisk=/boot/initrd-2.6.18-53.el5xen.img \
  kernel=/boot/vmlinuz-2.6.18-53.el5xen \
  name=test vif='' vcpus=1 memory=64 root=/dev/ram0
Comment 6 Richard W.M. Jones 2008-01-17 10:36:58 EST
Created attachment 292005 [details]
Patch to fix incorrect xm create documentation

This patch fixes the incorrect 'xm create' documentation in the manpage.
Comment 7 Daniel Berrange 2008-01-17 17:15:51 EST
Built for RHEL-5.2

Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
xen-3.0.3-46.el5                          dist-5E-qu-candidate  berrange
Comment 10 errata-xmlrpc 2008-05-21 11:19:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0305.html

Note You need to log in before you can comment on or make changes to this bug.