Bug 227877 - windows placement oddities with Desktop Effects on
windows placement oddities with Desktop Effects on
Status: CLOSED DUPLICATE of bug 230149
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-02-08 13:56 EST by Florin Andrei
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 22:18:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2007-02-08 13:56:45 EST
Description of problem:
Turn on Desktop Effects. Launch various apps.

The new windows are placed at the extreme top-left corner, window decorations
under the top panel.

Enable TwinView. Open Firefox and maximize it in the left screen (the one with
the panels). Open Thunderbird and maximize it in the right screen (the one
without panels). Open another app on top of Thunderbird.
Now click on the Thunderbird tab on the bottom panel to bring up Thunderbird.
Result: Thunderbird will jump to the left screen instead of showing up at the
top of the right screen (where it should be).

Version-Release number of selected component (if applicable):
compiz-0.3.6-2.fc7
kernel-2.6.20-1.2922.fc7
kmod-nvidia-1.0.9746-1.2.6.20_1.2922.fc7
07:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GT] (rev a1)

How reproducible:
always

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
see above

Expected results:
see above

Additional info:
Comment 1 Florin Andrei 2007-02-08 14:16:51 EST
With Desktop Effects on and TwinView:
Maximize a gnome-terminal in the left screen. Maximize a gnome-terminal in the
right screen.
In the right screen, hit F11 so that gnome-terminal goes full-screen.
Do some work.
Now hit F11 again in the right screen. The terminal will jump to the left screen.

NOTE: My desktop is configured with "select windows when the mouse moves over
them" turned on. I do not know what happens if I turn that off, never tried it.
Comment 2 Florin Andrei 2007-02-08 14:18:16 EST
Maximize Firefox in the left screen.
Maximize Thunderbird in the right screen.
In Thunderbird, click on a URL.
Firefox will open the URL in a new tab, but it will also jump off the left
screen. I think it goes to the right screen, hidden underneath Thunderbird.
Comment 3 David Nielsen 2007-02-08 22:38:34 EST
Can someone confirm this is not a Development problem, as this was pushed as a
testing update I think it would be prudent to block on this if it is valid on
FC6 as well. While I am on the QA team I simply don't have a Compiz capable
system available to do testing on FC6 since I moved into F7 testing fulltime.
Comment 4 Peter Gordon 2007-02-09 00:13:57 EST
David: I'm getting this on my FC6 desktop; but I must admit that my
Xorg/Mesa/DRI stack, kernel, and compiz/metacity (among others) are all pulled
from Development...
Comment 5 Eric Work 2007-02-13 04:13:52 EST
I was having this problem also until I added the "place" plugin.  I had some
other problems and reset my plugin list but this was not one of the defaults.
Comment 6 David Nielsen 2007-02-13 04:36:13 EST
Indeed that helps tremendously, why one wonders is this not on by default anymore?

Also the very useful scale plugin doesn't seem enabled by default either, it
seems to be warrenting at least a nice tick box in Desktop Effects as it's one
of the plugins that really makes Compiz useful.
Comment 7 vfiend 2007-02-13 06:19:54 EST
I was having the extreme-top-left corner problem too, I just upgraded to compiz
0.3.6-2 from the stable FC6 updates. I added the place plugin to the active
plugins list and it's working perfectly now.

This plugin should definitely be enabled by default, there will probably be a
huge amount of people having this problem now that the update's been pushed.
Comment 8 Bill Nottingham 2007-03-02 12:44:43 EST
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.
Comment 9 Bojan Smojver 2007-03-06 05:14:02 EST
I can confirm the top-upper-corner windows with F7T2 Live CD (when Desktop
Effects get turned on) and also with FC6, but only for users that haven't used
compiz prior to 0.3.x (this is obviously for FC6 only). For people that had
.gconf/apps/compiz before, it works fine (in fact, blowing away all that for new
users and replacing with with contents from someone else's pre-0.3.x
.gonf/apps/compiz fixes the problem).
Comment 10 Bojan Smojver 2007-03-06 05:15:06 EST
Where top-upper-corner is defined as upper-left-corner, of course ;-)
Comment 11 Will Woods 2007-03-28 11:38:30 EDT
So I guess the solution is to re-enable 'place' in the default plugin list?

Kristian, is there a reason it's been removed from the list? Would it be OK to
re-add it?
Comment 12 Kristian Høgsberg 2007-03-28 22:17:52 EDT
The plugin was never disabled, I think there's a bug in the desktop-effects
dialog  that drops it from the list when it reconfigures the plugin list.

Re-adding the plugin manually is a quick workaround for this problem, but I'll
see if I can come up with a real fix.
Comment 13 Kristian Høgsberg 2007-03-28 22:18:39 EDT

*** This bug has been marked as a duplicate of 230149 ***
Comment 14 David Nielsen 2007-03-29 07:39:54 EDT
It would be good to get this fixed sooner rather than later - it's already
causing bad PR both for us and for Compiz.

http://msevior.livejournal.com/15629.html

Note You need to log in before you can comment on or make changes to this bug.