Bug 227878 - spell checker dictionary installation should be documented and yumable
Summary: spell checker dictionary installation should be documented and yumable
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-08 18:58 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: FC-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-08 20:12:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2007-02-08 18:58:15 UTC
Installation of dictionaries should be automatic, with additional dictionaries
being available via yum.

Unless I'm horribly mistaken, the current recommended installation method seems
to be running a Star Office document (DicOOo.sxw) containing a macro and let it
download the dictionaries. This needs to be documented on the wiki (I didn't do
this because I'm not confident installation of a dictionary requires such a
convulated method.)

Comment 1 Caolan McNamara 2007-02-08 20:12:09 UTC
Indeed, and that's so horrible that we don't put DictOOo in our menus at all, we
already include most dictionaries directly into the appropiate langpacks in FC-6
e.g Afrikaans into the langpack-af rpm, instead of forcing the user to use
DictOOo to download them for their language. I think we already have the
available dictionaries for all the supported langpacks included for FC-6

And for FC-7 we'll split them out into standalone hunspell-af etc and require
them directly from the appropriate langpacks, and a user can simple yum install
hunspell-language to get additional dictionaries for that language.

Comment 2 Need Real Name 2007-02-08 20:44:11 UTC
Ah okay. The thing to look for is langpack then, not spell.
 yum list "openoffice*spell*"
and
 yum list "*spell*"
showed nothing. The wiki showed nothing about this either :/

FC7 sounds good, maybe there will be a unified dictionary one day :)

Comment 3 Caolan McNamara 2007-02-08 23:03:14 UTC
yeah, small steps towards trying to make some sanity of it all at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=207571 by at least sticking
OOo and firefox/thunderbird on top of a shared solution and dragging everyone
else along by gravitational pull


Note You need to log in before you can comment on or make changes to this bug.