Bug 227882 - Disabled checked boxes get selected on 'Select All'
Disabled checked boxes get selected on 'Select All'
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Partha Aji
wes hayutin
Depends On:
Blocks: rhn500h-config-mgmt
  Show dependency treegraph
Reported: 2007-02-08 14:23 EST by Partha Aji
Modified: 2007-04-18 13:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-12 22:38:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Partha Aji 2007-02-08 14:23:39 EST
Description of problem:
Disabled check boxes get selected on hitting the select all on Config Channel
subscriptions page

Version-Release number of selected component (if applicable): 
Rhn 500 Hosted + Satellite

How reproducible: 

Steps to Reproduce:
1. Login as a user with access to atleast 2 central config channels.
2. Register a system.
3. Through the SDC, provide the system , 'provisioning' entitlement. 
4. Click Configuration -> Manage Configuration Channels -> Subscribe to Channels.
5. Select a channel or two (DO NOT select ALL channels) and hit Conitnue annd
Update on Rank Channels page.
6. Again click Configuration -> Manage Configuration Channels -> Subscribe to
7. Notice that the previously selected check boxes are greyed out (disabled).
8. Hit the 'Select All' button.

Actual results:
All the check boxes are selected irrespective of whether they are disabled or
not. Also the pagination text shows "# selected" where # is the total number of
check boxes (Disabled + Non Disabled).

Expected results:
Only the non-disabled check boxes should be selected . Also the pagination text
should show "# selected" where # is the total number of ENABLED check boxes (Non
Comment 1 Partha Aji 2007-02-08 14:31:11 EST
This has been resolved...
Comment 2 Partha Aji 2007-02-15 17:16:11 EST
Moving to ON_QA
Comment 3 Partha Aji 2007-02-15 17:17:56 EST
Moving to ON_QA
Comment 4 wes hayutin 2007-02-19 09:21:06 EST
This appears to be working correctly..
Comment 5 wes hayutin 2007-03-06 10:33:16 EST
release pending
Comment 6 Brandon Perkins 2007-03-12 22:38:44 EDT
Closed in the rhn500h Release.

Note You need to log in before you can comment on or make changes to this bug.