Bug 227897 - openoffice.org-writer consumes all of memory
openoffice.org-writer consumes all of memory
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-08 15:35 EST by Jerry James
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.4-5.5.17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 03:51:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Word document that triggers bad Writer behavior (3.61 MB, application/msword)
2007-02-09 18:38 EST, Jerry James
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 74451 None None None Never

  None (edit)
Description Jerry James 2007-02-08 15:35:09 EST
Description of problem:
A student of mine tried to edit a Word document with OpenOffice and had her
workstation freeze up.  I reproduced with top running, and saw that Writer was
occupying more and more memory.  It hit 90% just before top stopped refreshing.
 Eventually, Writer closed (whether because it crashed or because it was unable
to allocate more memory and shut down; I don't know) and, after much swapping,
the workstation was back to normal.  This is completely reproducible.  The
student has given permission for me to submit the file in question (attached). 
For us, Writer opens normally and appears responsive.  But if we page down
several pages, we can see a point where a drawing appears to have been mangled
somehow, with boxes sticking out into the right margin.  At that point, the
workstation starts to become less and less responsive as Writer starts consuming
memory.  Note that the workstation in question has 1 GB of RAM, and the file is
less than 4 MB in size.

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.4-5.5.10

How reproducible:
Always

Steps to Reproduce:
1. Open the attached file in OpenOffice Writer
2. Page down until you see a page with boxes protruding into the right margin.

Actual results:
Writer consumes more and more memory until it closes.

Expected results:
Writer should allow normal editing of the file.

Additional info:
Comment 1 Caolan McNamara 2007-02-09 04:02:25 EST
Can you attach the document which causes this ?
Comment 2 Jerry James 2007-02-09 18:38:43 EST
Created attachment 147825 [details]
Word document that triggers bad Writer behavior

Sorry, I thought I had attached in when I first filed the bug.	In fact,
Firefox just autocompleted the Description field above for me, so I know I
typed it before.  I don't know what happened.
Comment 3 Caolan McNamara 2007-02-12 05:00:19 EST
reproducible on x86_64, ate my computer
Comment 4 Caolan McNamara 2007-02-12 09:08:32 EST
got it, will be in the next respin for FC-6
Comment 5 Caolan McNamara 2007-03-28 03:51:44 EDT
now in 2.0.4-5.5.17 in FC-6 updates

Note You need to log in before you can comment on or make changes to this bug.