Bug 227925 - xterm was added to the System menu
xterm was added to the System menu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-08 17:29 EST by Tim Reilly
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-16 09:02:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Reilly 2007-02-08 17:29:40 EST
Description of problem:
xterm (without an icon) was added to the System (formerly System Tools) in the
Applications menu. This seems like a mistake for a default install.
Comment 1 Miroslav Lichvar 2007-02-09 06:51:53 EST
Yes, this was requested in the package review, bug #226660. xterm shouldn't be
installed in default install.
Comment 2 Matthias Clasen 2007-02-09 10:57:50 EST
Not sure about the default install yet. Many people actually use xterm, so maybe
it should be in the default install.
Two problems with the current desktop file are

1) missing icon, as already pointed out

2) now we have one terminal in Accessories and one in System Tools
Comment 3 Tim Reilly 2007-02-12 13:16:44 EST
Yeah, those issues were my main reason for filing the bug. It doesn't make a
whole lot of sense to include two different terminals in the default install.
While a number of people might use xterm, it's not really a gnome desktop app...
Comment 4 Joachim Frieben 2007-02-13 08:36:08 EST
Adding "Icon=gnome-xterm.png" to "fedora-xterm.desktop" adds the right
icon to the menu entry. Btw, the title line "xterm Terminal" should be
replaced by "X Terminal". This is more succint and even looks better :)
Comment 5 Miroslav Lichvar 2007-02-16 09:02:33 EST
Icon=gnome-xterm.png is added to the desktop file in xterm-224-1.fc7.

But I didn't change the name to "X Terminal" since xterm isn't a X terminal,
it's a terminal emulator. I agree that "xterm Terminal" isn't very good, but at
least it follows the recommendation to use specific name and generic name.

Comment 6 Joachim Frieben 2007-02-16 10:36:18 EST
This logic is beyond me. Either it's a terminal emulator; then the right
entry is "X Terminal Emulator". If it's not a terminal, then it can
neither be an "X Terminal" nor an "xterm Terminal". I'm sorry, but here
you are contradicting yourself ..
Comment 7 Miroslav Lichvar 2007-02-16 11:47:06 EST
Ok, Terminal isn't absolutely correct. Problem is that X terminal displays X
applications and xterm is an X application which emulates a text terminal.

The best name for xterm is "Terminal emulator for X", but that doesn't follow
the recommendation.

We can still drop the desktop file. :)
Comment 8 Joachim Frieben 2007-02-16 12:36:58 EST
I'd go for "X Terminal Emulator" then - there are menus entries like
"Sound Juicer CD Extractor" which are definitely longer, so this
should be no argument.
Comment 9 Bill Nottingham 2007-03-02 12:33:47 EST
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.

Note You need to log in before you can comment on or make changes to this bug.