Bug 22793 - Unable to install Redhat Linux 7.0 on Pentium II
Unable to install Redhat Linux 7.0 on Pentium II
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-23 18:16 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-23 21:03:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-23 18:16:15 EST
Machine description:

Pentium II 300Mhz, with 128 MB, 2 ( IDE ) hard drives each of 6.3 GB of storage.
Initially I had partitioned the first hard drive into several partitions and installed 
RedHat Linux 5.2 with LILO boot method. I could use both Windows 95 and Linux.
I wanted to load the latest glibc library and ran into serious problems and decided to 
upgrade Redhat Linux itself. I bought a copy of Redhat Linux 7.0 ( Product ID
3873-2fc3-293a-ee39 ). I could not upgrade from 5.2 to 7.0 as the /usr partition
was not sufficiently big to load the minimal configuration. Therefore I decide to 
repartition and the following is the partition table info.

I have partitioned the first hard drive ( /dev/hda ) into several partitions

Device        Start         End            Blocks           Id              System                           Mounted on

/dev/hda1     1             261             2096451       6             DOS-16bit>= 32M           /dos
/dev/hda2     262         782            42009971     5              Extended
/dev/had5    262          300            313236        83             Linux Native                     /
/dev/had6    301          504            1638594      83             Linux Native                    /usr
/dev/had7    505          632            1028128      83             Linux Native                    /usr/local
/dev/had8    633          760            1028128      83             Linux Native                    /home
/dev/had9    761          773            104391        82             Linux Swap                     <swap>

/dev/hdb1      1             784            6GB              6             Windows95 format        /dos2


Actually I deleted the old unix partitions and rearraged the partitions to accomodate the RedHat Linux 7.0.
I am able to go upto the very end of installation using the CD1 and at the end I get the following message
to be reported to bugzilla.redhat.com/bugzilla. Therefore I am submitting this  bug report.
I am able to start and work using windows 95 as before. Can anyone help me?

Traceback (innermost last):
  
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in doInstall
    
if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
  
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in systemMounted
    
self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, 
in filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + 
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    
return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')


Local variables in innermost frame:
fsystem: 

I above statement was one huge line and I have broken into manageable pieces.

Thanks
Seshari Rengarajan
srengarajan@yahoo.com
/mnt/sysimage//dos

ToDo 
object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage

CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>



Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc = self.todo.doInstall ()
 
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in doInstall
  if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in systemMounted
    self.loopbackFile = 
mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in 
fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')Local variables in innermost frame:
fsystem: /mnt/sysimage//dos

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Sean McPherson 2000-12-23 21:03:36 EST
It looks like you had the /dev/hda1 Dos/Windows partition attempting to mount 
as /dos (/mnt/sysimage is  the location anaconda is holding the system data a s 
it installs), and  that the /dos directory was not properly created by the 
setup. Did you through fdisk or disk druid more than once? Also, had you 
created that partition manually, and formatted it, or just created it in the 
partitioner?
Comment 2 Daniel Roesen 2000-12-27 05:37:33 EST
Errata update available. See
http://www.redhat.com/support/errata/RHBA-2000-084-04.html

*** This bug has been marked as a duplicate of 18032 ***
Comment 3 Need Real Name 2000-12-28 09:44:56 EST
Yes, that is correct. /dev/hda1 ( Dos/Windows ) partition was left untouched 
while repartitioning the old Redhat5.2 linux partitions. After recreating these
linux partitions I did format using fdisk. I created partitions manually and before
upgrade or install was done I said yes to format option. Then at the end of
installation I got the above messages. Thanks for your efforts. However,
I have fixed the problem. I dont know whether that is the genuine solution
or not. Here it what I did to install Redhat 7.0.

Afte repeated attempts of readjusting partition table to increase /usr and /usr/local
file systems ( on /dev/hda5 and /dev/hda6 ) I reinstalled Redhat 5.2 with the 
Redhat 5.2 boot floopy and the respective CD-ROM. The 5.2 installation
went through without a glitch. Then I used the Redhat 7.0 boot floopy to upgrade the
linux and followed the instructions. I chose the default settings for upgrade and
this time as well I did not have any problem. Now I have my Redhat 7.0 running
smoothly ( kernel 2.2.16 ). Once again thanks for your efforts. Please consider
this bug to be fixed/closed.

Note You need to log in before you can comment on or make changes to this bug.