Bug 227938 - NULL pointer BUG in snd_interval_list
NULL pointer BUG in snd_interval_list
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-08 18:34 EST by Patrick Monnerat
Modified: 2011-12-13 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.20-1.2925
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 15:16:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 7681 None None None Never

  None (edit)
Description Patrick Monnerat 2007-02-08 18:34:21 EST
Description of problem:
Random occurrence of the bug below. The audio output then stops working until
next reboot.

Version-Release number of selected component (if applicable):
-2.6.19-1.2895.fc6

How reproducible:
Don't know... random bug, but occurs often. Sorry!

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Audio stops working

Expected results:
No BUG! Audio stays OK

Additional info:
Audio device: 00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER
(ICH5/ICH5R) AC'97 Audio Controller (rev 02)

Excerpts from /var/log/message:
eb  8 21:44:56 localhost kernel: BUG: unable to handle kernel NULL pointer
dereference at virtual address 00000001
Feb  8 21:44:56 localhost kernel:  printing eip:
Feb  8 21:44:56 localhost kernel: e0a4186f
Feb  8 21:44:56 localhost kernel: *pde = 1b440067
Feb  8 21:44:56 localhost kernel: Oops: 0000 [#1]
Feb  8 21:44:56 localhost kernel: SMP 
Feb  8 21:44:56 localhost kernel: last sysfs file:
/devices/pci0000:00/0000:00:1d.7/usb5/5-6/5-6:1.1/usbdev5.3_ep81/dev
Feb  8 21:44:56 localhost kernel: Modules linked in: ppdev autofs4 hidp rfcomm
l2cap bluetooth sunrpc ip_conntrack_netbios_ns ipt_REJECT xt_state ip_conntrack
nfnetlink iptable_filter ip_tables ip6t_REJECT xt_tcpudp ip6table_filter
ip6_tables x_tables nls_utf8 ntfs(U) dm_multipath video sbs i2c_ec button
battery asus_acpi ac ipv6 lp snd_intel8x0 snd_ac97_codec snd_ac97_bus
snd_seq_dummy snd_seq_oss uvcvideo(U) snd_seq_midi_event snd_usb_audio snd_seq
nvidia(P)(U) snd_pcm_oss snd_mixer_oss snd_usb_lib ohci1394 videodev snd_pcm
v4l1_compat i2c_i801 iTCO_wdt floppy skge ieee1394 v4l2_common snd_timer
snd_rawmidi ide_cd usblp pcspkr snd_page_alloc snd_seq_device i2c_core serio_raw
snd_hwdep snd cdrom parport_pc soundcore parport dm_snapshot dm_zero dm_mirror
dm_mod ata_piix libata sd_mod scsi_mod ext3 jbd ehci_hcd ohci_hcd uhci_hcd
Feb  8 21:44:56 localhost kernel: CPU:    1
Feb  8 21:44:56 localhost kernel: EIP:    0060:[<e0a4186f>]    Tainted: P      VLI
Feb  8 21:44:56 localhost kernel: EFLAGS: 00210202   (2.6.19-1.2895.fc6 #1)
Feb  8 21:44:56 localhost kernel: EIP is at snd_interval_list+0x21/0xa6 [snd_pcm]
Feb  8 21:44:56 localhost kernel: eax: 00000001   ebx: c2f60928   ecx: 00000000
  edx: 00000001
Feb  8 21:44:56 localhost kernel: esi: 00000013   edi: c2f60800   ebp: ffffffff
  esp: dd70fcec
Feb  8 21:44:56 localhost kernel: ds: 007b   es: 007b   ss: 0068
Feb  8 21:44:56 localhost kernel: Process firefox-bin (pid: 3123, ti=dd70f000
task=dd84c370 task.ti=dd70f000)
Feb  8 21:44:56 localhost kernel: Stack: dd70fe00 c2f60800 c2f60800 dd70fe34
e0a436d4 ffffffff c49d7ee0 00000017 
Feb  8 21:44:56 localhost kernel:        e0a3fad8 00000002 00000003 00000004
00000005 00000006 00000007 00000008 
Feb  8 21:44:56 localhost kernel:        00000009 0000000a 0000000b 0000000c
0000000d 0000000e 0000000f 00000010 
Feb  8 21:44:56 localhost kernel: Call Trace:
Feb  8 21:44:56 localhost kernel:  [<e0a436d4>] snd_pcm_hw_rule_list+0x25/0x29
[snd_pcm]
Feb  8 21:44:56 localhost kernel:  [<e0a3fad8>] snd_pcm_hw_refine+0x260/0x3b8
[snd_pcm]
Feb  8 21:44:56 localhost kernel:  [<e0a52107>]
snd_pcm_oss_change_params+0x1a8/0xc4f [snd_pcm_oss]
Feb  8 21:44:56 localhost kernel:  [<e0a52eeb>]
snd_pcm_oss_get_active_substream+0x2c/0x43 [snd_pcm_oss]
Feb  8 21:44:56 localhost kernel:  [<e0a52f2c>] snd_pcm_oss_get_formats+0xe/0xf9
[snd_pcm_oss]
Feb  8 21:44:56 localhost kernel:  [<e0a53f9d>] snd_pcm_oss_ioctl+0x366/0x9ca
[snd_pcm_oss]
Feb  8 21:44:56 localhost kernel:  [<c048022b>] do_ioctl+0x1f/0x62
Feb  8 21:44:56 localhost kernel:  [<c04804b8>] vfs_ioctl+0x24a/0x25c
Feb  8 21:44:56 localhost kernel:  [<c0480516>] sys_ioctl+0x4c/0x66
Feb  8 21:44:56 localhost kernel:  [<c040404b>] syscall_call+0x7/0xb
Feb  8 21:44:56 localhost kernel:  [<00a17402>] 0xa17402
Feb  8 21:44:56 localhost kernel:  =======================
Feb  8 21:44:56 localhost kernel: Code: 83 c4 40 89 c8 5b 5e 5f 5d c3 55 57 56
89 d6 53 8b 6c 24 14 89 ca 89 c3 31 c9 eb 21 85 ed 74 0b b8 01 00 00 00 d3 e0 85
c5 74 11 <8b> 04 8a 39 03 75 08 f6 43 08 01 75 04 eb 16 72 07 41 39 f1 75 
Feb  8 21:44:56 localhost kernel: EIP: [<e0a4186f>] snd_interval_list+0x21/0xa6
[snd_pcm] SS:ESP 0068:dd70fcec
Comment 1 Chuck Ebbert 2007-02-09 14:13:55 EST
oops changed wrong bug
Comment 2 Penelope Fudd 2007-02-10 18:16:47 EST
I'm getting this too: kernel-2.6.18-1.2869.fc6.i686

Feb  9 08:54:27 kirk kernel: BUG: unable to handle kernel NULL pointer
dereference at virtual address 00000001
Feb  9 08:54:27 kirk kernel:  printing eip:
Feb  9 08:54:27 kirk kernel: f89e986f
Feb  9 08:54:27 kirk kernel: *pde = 1560a067
Feb  9 08:54:27 kirk kernel: Oops: 0000 [#1]
Feb  9 08:54:27 kirk kernel: SMP
Feb  9 08:54:27 kirk kernel: last sysfs file:
/devices/pci0000:00/0000:00:1e.0/0000:02:09.0/irq
Feb  9 08:54:27 kirk kernel: Modules linked in: ppdev autofs4
ip_conntrack_netbios_ns ipt_MASQUERADE iptable_nat ip_nat ipt_REJECT xt_state
ip_conntrack nfnetlink iptable_filter ip_tables ip6t_REJECT xt_tcpudp
ip6table_filter ip6_tables x_tables vfat fat loop dm_multipath video sbs i2c_ec
button battery asus_acpi ac ipv6 lp sg snd_intel8x0 snd_ac97_codec snd_ac97_bus
snd_seq_dummy snd_usb_audio snd_seq_oss snd_seq_midi_event snd_seq nvidia(P)(U)
snd_pcm_oss snd_mixer_oss iTCO_wdt snd_pcm floppy i2c_i801 usblp snd_timer
serio_raw i2c_core snd_page_alloc snd_usb_lib snd_rawmidi ide_cd snd_seq_device
parport_pc e100 parport snd_hwdep mii cdrom snd soundcore pcspkr usb_storage
dm_snapshot dm_zero dm_mirror dm_mod ata_piix libata sd_mod scsi_mod ext3 jbd
ehci_hcd ohci_hcd uhci_hcd
Feb  9 08:54:27 kirk kernel: CPU:    1
Feb  9 08:54:27 kirk kernel: EIP:    0060:[<f89e986f>]    Tainted: P      VLI
Feb  9 08:54:27 kirk kernel: EFLAGS: 00210202   (2.6.19-1.2895.fc6 #1)
Feb  9 08:54:27 kirk kernel: EIP is at snd_interval_list+0x21/0xa6 [snd_pcm]
Feb  9 08:54:27 kirk kernel: eax: 00000001   ebx: d1d70d28   ecx: 00000000  
edx: 00000001
Feb  9 08:54:27 kirk kernel: esi: 00000013   edi: d1d70c00   ebp: ffffffff  
esp: d5437cf0
Feb  9 08:54:27 kirk kernel: ds: 007b   es: 007b   ss: 0068
Feb  9 08:54:27 kirk kernel: Process firefox-bin (pid: 4117, ti=d5437000
task=d5579770 task.ti=d5437000)
Feb  9 08:54:27 kirk kernel: Stack: d5437e00 d1d70c00 d1d70c00 d5437e34 f89eb6d4
ffffffff d1d706e0 00000017
Feb  9 08:54:27 kirk kernel:        f89e7ad8 ffffffff ffffffff 00000000 00000002
00000003 00000004 00000005
Feb  9 08:54:27 kirk kernel:        00000006 00000007 00000008 00000009 0000000a
0000000b 0000000c 0000000d
Feb  9 08:54:27 kirk kernel: Call Trace:
Feb  9 08:54:27 kirk kernel:  [<f89eb6d4>] snd_pcm_hw_rule_list+0x25/0x29 [snd_pcm]
Feb  9 08:54:27 kirk kernel:  [<f89e7ad8>] snd_pcm_hw_refine+0x260/0x3b8 [snd_pcm]
Feb  9 08:54:27 kirk kernel:  [<f89fa107>] snd_pcm_oss_change_params+0x1a8/0xc4f
[snd_pcm_oss]
Feb  9 08:54:27 kirk kernel:  [<f89faeeb>]
snd_pcm_oss_get_active_substream+0x2c/0x43 [snd_pcm_oss]
Feb  9 08:54:27 kirk kernel:  [<f89faf2c>] snd_pcm_oss_get_formats+0xe/0xf9
[snd_pcm_oss]
Feb  9 08:54:27 kirk kernel:  [<f89fbf9d>] snd_pcm_oss_ioctl+0x366/0x9ca
[snd_pcm_oss]
Feb  9 08:54:27 kirk kernel:  [<c048022b>] do_ioctl+0x1f/0x62
Feb  9 08:54:27 kirk kernel:  [<c04804b8>] vfs_ioctl+0x24a/0x25c
Feb  9 08:54:27 kirk kernel:  [<c0480516>] sys_ioctl+0x4c/0x66
Feb  9 08:54:27 kirk kernel:  [<c040404b>] syscall_call+0x7/0xb
Feb  9 08:54:27 kirk kernel:  [<007a5402>] 0x7a5402
Feb  9 08:54:27 kirk kernel:  =======================
Feb  9 08:54:27 kirk kernel: Code: 83 c4 40 89 c8 5b 5e 5f 5d c3 55 57 56 89 d6
53 8b 6c 24 14 89 ca 89 c3 31 c9 eb 21 85 ed 74 0b b8 01 00 00 00 d3 e0 85 c5 74
11 <8b> 04 8a 39 03 75 08 f6 43 08 01 75 04 eb 16 72 07 41 39 f1 75
Feb  9 08:54:27 kirk kernel: EIP: [<f89e986f>] snd_interval_list+0x21/0xa6
[snd_pcm] SS:ESP 0068:d5437cf0

Comment 3 Penelope Fudd 2007-02-10 18:17:34 EST
And it's random.
Comment 4 Dave Jones 2007-03-19 16:47:28 EDT
Please retest this without the proprietary binary modules loaded.
Comment 5 Patrick Monnerat 2007-04-02 15:03:57 EDT
The latest kernel doesn't "Oops" anymore, so I did not perform the test 
required above... but:
_ One thing I omitted to mention is that a "quickcam pro 5000" is also 
connected to this system... Although this cam does not have sound output (and 
is unused by Linux!), it seems there is a race at init time between the sound 
card and the quickcam microphone, and the later may be considered as the 
default sound device. After reboot, it sometimes work, sometimes not. The 
initial problem with kernel 2.6.19-1.2895.fc6 was probably related to USB 
sound, as external reference http://bugme.osdl.org/show_bug.cgi?id=7681 may 
suggest.
_ The new problem has been partially solved according to bug #229227 comments 
(adapted to my hardware configuration). Mainly by not using sndconfig (edit 
modprobe.conf manually) and by creating an appropriate /etc/asound.conf file. 
However, some soundy applications (i.e.: some firefox plugins) still do not 
work.
Comment 6 Patrick Monnerat 2007-04-02 15:16:31 EDT
Closing the bug, since it doesn't occur anymore in its original form.

Note You need to log in before you can comment on or make changes to this bug.