Bug 22798 - upgrade from 6.1 to 7.0 libkrb5 files are missing for samba, lpd, imap/pop3
Summary: upgrade from 6.1 to 7.0 libkrb5 files are missing for samba, lpd, imap/pop3
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: krb5 (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-24 04:25 UTC by Craig White
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 18:31:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Craig White 2000-12-24 04:25:36 UTC
try to start lpd and get: 
 lpd: error while loading shared libraries: libkrb5.so.3: cannot open shared object file: No such file or directory

check mail with mail client from another computer (worked fine before upgrade)
 Server response: ipop3d: error while loading shared libraries: libgssapi_krb5.so.2: cannont open shared object file: No such file or directory

try to start checkpc and get:
 checkpc: error while loading shared libraries: libkrb5.so.3: cannot open shared object file: No such file or directory

try to start samba and get:
 smbd: error while loading shared libraries: libdes425.so.3: cannot open shared object file: No such file or directory

have installed the following updates & bug fixes...LPR/cpp/emacs/fetchmail/gcc/glibc/libstdc/modutils/nscd/openssh/pam/usermode/xinetd

indeed have the kerberos libraries installed in /usr/kerberos and have in desperation created symbolic links in /usr/lib

HELP ! ! !

Comment 1 Bill Nottingham 2000-12-24 04:40:24 UTC
What's your /etc/ld.so.conf look like?

Comment 2 Craig White 2000-12-24 04:49:22 UTC
/usr/X11R6/lib
/usr/lib
/usr/i486-linux-libc5/lib
/usr/lib/qt-2.0.1/lib
/usr/lib/qt-1.44/lib
/usr/local/lib/usr/kerberos/lib
/usr/lib/qt-2.2.0/lib
/usr/lib/qt-1.45/lib
/usr/lib/mysql


Comment 3 Craig White 2000-12-24 17:54:08 UTC
OK - turns out that what I needed to do was to 'force' a rpm install of the krb libraries to make things work.

rpm -ivvh --force krb5-libs-1.21.i386.rpm

can't understand why they were partially installed on upgrade but that solved things

Comment 4 Bill Nottingham 2000-12-25 04:09:56 UTC
It failed because /usr/kerberos/lib wasn't in your /etc/ld.so.conf.
I'd guess that whatever added /usr/local/lib didn't end the
file with a newline.

Comment 5 Nalin Dahyabhai 2001-01-16 02:34:50 UTC
Bill's right about that last bit.  The addition of /usr/kerberos/lib to the
ld.so.conf happens in the post-install of the krb5-libs package.  Adding an
extra newline to the file across all packages which manipulate the file isn't
really feasible.

If you run "rpm -qai --scripts" and search the script snippets for scripts which
manipulate /etc/ld.so.conf, you can probably isolate the package which does
this.


Note You need to log in before you can comment on or make changes to this bug.