Bug 227999 - High frequency tome from hardware
High frequency tome from hardware
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-09 08:57 EST by Amadeus
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 18:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amadeus 2007-02-09 08:57:34 EST
Most recent kernel where this bug did *NOT* occur: 2.4.19

Distribution: Red Hat Enterprise Linux 4, Fedora Core 6, Ubuntu 5.

Hardware Environment: IBM ThinkPad T23. See complete list of hardware at
http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-4YTG43

Software Environment: None. The bug occures right after the kernel have been
uncompressed.



Problem Description:
A high frequent tone comes from the hardware near the USB connectors right after
the 2.6.x kernel have been uncompressed.

The tone is there everytime the harddrive loads or saves. When the harddrive
doesn't do any of this, the tone is gone.

Inserting a USB key inverses the problem.

When a USB key is inserted, the tone is present when the harddisk doesn't load
or save, and comes back when it loads and saves.

I have tested it with two different harddrives, and it difficult to tell from
what peice of hardware the tone comes from, but it is not from the harddrive. It
is from somewhere near the USB connectors.

Using the FSF membership cd LNX-BBC 2.1 with kernel 2.4.19-xfs i686 works perfectly.



Steps to reproduce:
* Boot any 2.6 kernel
* Wait till the kernel is uncompressed, and a high frequent tone appears from
the hardware.
Comment 1 Amadeus 2007-02-09 11:47:40 EST
The problem is explained and "resolved" in
http://bugzilla.kernel.org/show_bug.cgi?id=7973#c3


So fixing it for real will require that:

if laptop
  timer interrupt == 100Hz
fi

Comment 2 Jason Baron 2007-03-02 16:03:42 EST
interesting. As you point out we would have to re-compile the kernel to fix
this. We are not going to change this setting to fix a boot tone, as this would
be too risky a change for what is not a very serious problem afaict. If we can
come up with a less invasive fix for this we would be happy to consider it.
however, i would not consider this a high priority issue for us...
Comment 3 Amadeus 2007-03-06 04:38:14 EST
It is not just present when the kernel boots. It is preset at all times.
Comment 4 Alan Cox 2007-04-13 18:27:17 EDT
This is a hardware not a software problem. HZ is a kernel constant so it would
require a new kernel, breaking binary module compatibility and major reworking.

Thus I'm going to close this as WONTFIX


Note You need to log in before you can comment on or make changes to this bug.