Bug 228043 - ??? 64bit sa-update.1 manpage timestamp differs from 32bit?
??? 64bit sa-update.1 manpage timestamp differs from 32bit?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Warren Togami
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-09 13:07 EST by Warren Togami
Modified: 2008-05-07 04:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 04:09:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-02-09 13:07:14 EST
Odd minor problem... low priority.

/usr/share/man/man1/sa-update.1.gz differs by the following unidiff between the
32bit and 64bit architecture builds of spamassassin.

--- 32  2007-02-09 12:46:19.000000000 -0500
+++ 64  2007-02-09 12:46:10.000000000 -0500
@@ -129,7 +129,7 @@
 .\" ========================================================================
 .\"
 .IX Title "SA-UPDATE 1"
-.TH SA-UPDATE 1 "2006-07-30" "perl v5.8.5" "User Contributed Perl Documentation"
+.TH SA-UPDATE 1 "2007-01-22" "perl v5.8.5" "User Contributed Perl Documentation"
 .SH "NAME"
 sa\-update \- automate SpamAssassin rule updates
 .SH "SYNOPSIS"

This appears to be the only difference in version 3.1.7.  Notice that the 32bit
version retained the original source timestamp, while the 64bit version somehow
decided to differ in this behavior by changing the timestamp to the build date.
 The above example is 3.1.7 built on RHEL4, but this persists through perl-5.8.8
in FC7 too.

While this appears to create a multilib conflict, in practice this is not a real
problem because spamassassin is based on perl, and we don't ship both archs in a
multilib distribution.

This bug is merely to figure out *why* it is behaving in this strange way
betweeen 32bit and 64bit builds.
Comment 1 Warren Togami 2007-02-09 13:08:39 EST
Oops, spamd.1 manpage also differs.
Comment 2 Bug Zapper 2008-04-03 15:04:34 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 3 Bug Zapper 2008-05-06 21:09:20 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp
Comment 4 Paul Howarth 2008-05-07 04:02:17 EDT
This issue is still present in Fedora 8:

$ rpm -qlpv spamassassin-3.2.4-1.fc8.i386.rpm | grep -E '(sa-update|spamd).1'
-r--r--r--    1 root    root             4812 Jan  7 18:46
/usr/share/man/man1/sa-update.1.gz
-r--r--r--    1 root    root            10310 Jan  7 18:46
/usr/share/man/man1/spamd.1.gz

$ rpm -qlpv spamassassin-3.2.4-1.fc8.x86_64.rpm | grep -E '(sa-update|spamd).1'
-r--r--r--    1 root    root             4812 Jan  7 18:47
/usr/share/man/man1/sa-update.1.gz
-r--r--r--    1 root    root            10310 Jan  7 18:47
/usr/share/man/man1/spamd.1.gz
Comment 5 Paul Howarth 2008-05-07 04:09:14 EDT
Whoops, this bug is referring to the timestamp *in* the file rather than the
timestamp *of* the file. In spamassassin-3.2.4-1.fc8 these files are identical
in content between i386 and x86_64 so I'll close the bug again. Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.