Bug 22806 - xfree86 4.0.1 does not work on Sony PCG-SR17K
xfree86 4.0.1 does not work on Sony PCG-SR17K
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-24 13:35 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-24 13:35:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-24 13:35:03 EST
XFree86, plus the S3 Savage/MX driver from Tim Probo does not work on my
Sony PCG-SR17k.  It is not a bug introduced by the redhat version, but both
the redhat and compiled-from-source versions suffer from these symptoms:

the X server starts, gets a short way (starts to initialize the graphic
video mode - blank black screen), and spins, consuming 100% of the cpu,
getting nowhere.  Kill -9 is required to stop the server, and you can
never get any of the text consoles back either via ctrl-altF1-F6 or chvt
1-6.  suspend/resume doesn't re-init the gfx back to text mode either. a
reboot is required.

THe fix is to compile/install 4.0.2.  Something in the source is just
fixed.  This may affect other systems, other video subsystems, but it at
least affects mine.  In addition, 4.0.2 comes with the S3 Savage/MX (and
/IX) driver already with, so no extra work is required, even though adding
Tim Probo's driver isn't that hard (copy 3 files to the right
/usr/X11R6/modules/... directories)

   - Kevin Wang, kjw@rightsock.com
Comment 1 Bill Nottingham 2000-12-28 14:21:15 EST
4.0.2 is currently in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.