Bug 2280743
| Summary: | mgr/stats: fix AttributeError in perf_stats.py --> re_register_queries() | |||
|---|---|---|---|---|
| Product: | [Red Hat Storage] Red Hat Ceph Storage | Reporter: | Jos Collin <jcollin> | |
| Component: | CephFS | Assignee: | Jos Collin <jcollin> | |
| Status: | CLOSED ERRATA | QA Contact: | Hemanth Kumar <hyelloji> | |
| Severity: | medium | Docs Contact: | ||
| Priority: | high | |||
| Version: | 6.1 | CC: | ceph-eng-bugs, cephqe-warriors, gfarnum, hyelloji, jcaratza, rpollack, tserlin, vshankar | |
| Target Milestone: | --- | Flags: | hyelloji:
needinfo+
|
|
| Target Release: | 6.1z7 | |||
| Hardware: | All | |||
| OS: | Linux | |||
| Whiteboard: | ||||
| Fixed In Version: | ceph-17.2.6-234 | Doc Type: | Bug Fix | |
| Doc Text: |
.FSPerfStats:re_register_queries() is no longer called
unexpectedly when creating new file systems
Previously, whenever the stats plugin was enabled and a new File System was created, the fsmap observers were notified. As a result, FSPerfStats:re_register_queries() would be unexpectedly called, causing errors in mgr logs.
With this fix, self.mx_last_updated in FSPerfStats::init is initialized, and errors no longer occur in the mgr logs.
|
Story Points: | --- | |
| Clone Of: | ||||
| : | 2280748 2280750 (view as bug list) | Environment: | ||
| Last Closed: | 2024-08-28 17:58:19 UTC | Type: | Bug | |
| Regression: | --- | Mount Type: | --- | |
| Documentation: | --- | CRM: | ||
| Verified Versions: | Category: | --- | ||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | ||
| Cloudforms Team: | --- | Target Upstream Version: | ||
| Embargoed: | ||||
| Bug Depends On: | ||||
| Bug Blocks: | 2280748, 2280750 | |||
|
Description
Jos Collin
2024-05-16 05:05:19 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory (Red Hat Ceph Storage 6.1 security, bug fix, and enhancement updates.), and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2024:5960 |