Bug 228082 - Wrappers need to support legacy bundled builds
Summary: Wrappers need to support legacy bundled builds
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Directory Server (Show other bugs)
(Show other bugs)
Version: 1.0.4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 152373 240316 FDS1.1.0
TreeView+ depends on / blocked
 
Reported: 2007-02-09 21:47 UTC by Nathan Kinder
Modified: 2015-12-07 16:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 16:40:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Fix (2.88 KB, patch)
2007-02-09 21:51 UTC, Nathan Kinder
no flags Details | Diff
Revised Diffs (3.02 KB, patch)
2007-02-09 23:19 UTC, Nathan Kinder
no flags Details | Diff
CVS Commit (1.46 KB, text/plain)
2007-02-09 23:31 UTC, Nathan Kinder
no flags Details

Description Nathan Kinder 2007-02-09 21:47:02 UTC
We still need to support legacy-style bundled builds where we bundle all of our
run-time dependencies with the directory server itself.

With the current build-system, we use the library paths that are used at
link-time to set the library search path in our wrapper scripts.  This will not
work for the old style bundled builds.  We should only be using libpath
(/opt/fedora-ds/lib by default) in the wrappers.

Comment 1 Nathan Kinder 2007-02-09 21:51:05 UTC
Created attachment 147818 [details]
Proposed Fix

The fix adds a new "--enable-bundle" configure option that will only be used
for legacy-style packaging.  Using this option will make the build use a
different sed command for wrapper creation.

Comment 2 Rich Megginson 2007-02-09 22:02:19 UTC
OK, but you might need to add svrcore_libdir, perldap_libdir, and icu_libdir.

Comment 3 Noriko Hosoi 2007-02-09 22:04:45 UTC
Looks good to me.
(So, there's no platform restriction for --enable-bundle.  If we wish, we can do
it on RHEL and Solaris, as well.  It's nice to have the way!)

Comment 4 Nathan Kinder 2007-02-09 22:16:50 UTC
(In reply to comment #2)
> OK, but you might need to add svrcore_libdir, perldap_libdir, and icu_libdir.

I intend to have all of those libraries placed in libdir by the packaging script
(to-be-written).

Comment 5 Rich Megginson 2007-02-09 22:21:15 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > OK, but you might need to add svrcore_libdir, perldap_libdir, and icu_libdir.
> 
> I intend to have all of those libraries placed in libdir by the packaging script
> (to-be-written).

OK.

Comment 6 Nathan Kinder 2007-02-09 23:19:02 UTC
Created attachment 147822 [details]
Revised Diffs

This new set of diffs merges in some changes that Rich checked in since the
previous attachment.  The only change is the addition of a few more
substitutions in the sed command.

Comment 7 Rich Megginson 2007-02-09 23:24:42 UTC
(In reply to comment #6)
> Created an attachment (id=147822) [edit]
> Revised Diffs
> 
> This new set of diffs merges in some changes that Rich checked in since the
> previous attachment.  The only change is the addition of a few more
> substitutions in the sed command.

Ok.

Comment 8 Nathan Kinder 2007-02-09 23:31:58 UTC
Created attachment 147824 [details]
CVS Commit

Checked into ldapserver (HEAD).  Thanks to Rich and Noriko for their reviews!


Note You need to log in before you can comment on or make changes to this bug.