Bug 228088 - chkconfig support
chkconfig support
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fuse (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/FCNewInit
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-09 16:59 EST by Curtis Doty
Modified: 2008-07-06 02:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-06 02:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Curtis Doty 2007-02-09 16:59:51 EST
# chkconfig --list fuse
service fuse does not support chkconfig

Fixing this takes just a couple comment lines in the initscript. And now that
Extras and Core are merging, it's more important than ever.
Comment 1 Peter Lemenkov 2007-03-02 15:19:38 EST
How?
I personally don't use chkconfig at all so I can't fix it. Possibly someone can?
If you provide a patch I'll apply it ASAP.
Comment 2 Curtis Doty 2007-03-06 15:46:26 EST
It's just a comment line or two at the top of your script. I'm amazed this isn't
mandatory for Fedora.

Take a look at /usr/share/doc/initscripts-*/sysvinitfiles and/or peek at just
about any other script in /etc/init.d/ for examples. Since the fuse initscript
really only loads a module and tickles sysfs, it could be done early at same
time as netfs. Maybe something like this is enough for starters?

# chkconfig: 345 25 75
Comment 3 Eric Sandeen 2007-11-04 22:00:54 EST
here's a patch.  I think starting in all runlevels (12345) is ok, and the
start/stop levels (25, 75) are probably ok at least for starters, though testing
might be good.

--- /etc/init.d/fuse.orig       2007-11-04 20:40:18.000000000 -0600
+++ /etc/init.d/fuse    2007-11-04 20:55:04.000000000 -0600
@@ -11,6 +11,9 @@
 #	filesystem.
 ### END INIT INFO
 
+# chkconfig: 12345 25 75
+# Description: Load the fuse module and mount the fuse control filesystem.
+
 set -e
 
 PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin

Comment 4 Peter Lemenkov 2007-11-05 04:43:32 EST
Ok, thanks.
I'll apply this patch asap.
Comment 5 Curtis Doty 2007-11-05 09:11:27 EST
Please don't run fuse in single mode.

Also, it looks like Fedora is moving forward with LSB support. And since this
bug languished for so long now, it really should use that format. The URL to the
Fedora New Init System wiki page is added to this bug, FYI.
Comment 6 Eric Sandeen 2007-11-05 09:51:43 EST
Curtis, skipping fuse in single user is fine with me, I didn't have any idea if
it should be run there or not.  It's not doing much, but I don't really care
either way. :)

Peter, you can just change it to:

+# chkconfig: 345 25 75

as Curtis originally suggested, if you agree with this.

Even if Fedora is moving forward w/ LSB initscript support, wouldn't it still be
nice to have old chkconfig working properly in, say, F8 via a fuse pkg update?
Comment 7 Curtis Doty 2007-11-06 14:50:21 EST
Yep, it should have both chkconfig and LSB...for now.
Comment 8 Fedora Update System 2008-02-21 02:17:54 EST
fuse-2.7.3-1.fc8 has been submitted as an update for Fedora 8
Comment 9 Fedora Update System 2008-02-21 02:17:57 EST
fuse-2.7.3-1.fc7 has been submitted as an update for Fedora 7
Comment 10 Fedora Update System 2008-02-25 19:24:34 EST
fuse-2.7.3-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fuse'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1949
Comment 11 Bug Zapper 2008-05-13 22:36:04 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.